Problems with l4linux

Valery V. Sedletski _valerius at
Mon Oct 20 05:56:36 CEST 2008

On Sun, 19 Oct 2008 21:20:09 +0200, Adam Lackorzynski wrote:

>> >> Fourth, I thied a wifi MiniPCI card Intel PRO/Wireless 2200 to get
>> >> working in l4linux. I tried to load all wifi modules like in ordinary
>> >> Linux kernel on the same machine, but when I trying to make the
>> >> network interface up, it says that device does not exists. When I
>> >> check dmesg output, there is a message that a firmware could not be
>> >> loaded. I unchecked the checkbox "Prevent the firmware from being
>> >> built" and "Do not enable drivers which require firmware loading" and
>> >> it seems that firmware must be built. The firmware is in /lib/firmware
>> >> and is called ipw2200-bss.fw. What should I do to get firmware loaded?
>> >
>> >The FW_LOADER config option is not enabled. I guess this needs to be so.
>> I had CONFIG_FW_LOADER enabled but there was "CONFIG_FW_LOADER=m",
>Looking more closely the .config did not seem complete.
>> not "CONFIG_FW_LOADER=y". I changed this option to the latter and recompiled 
>> the kernel, but firmware still not loading. So, it won't help. The error is like this:
>> Oct 17 15:10:49 localhost kernel: ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
>> Oct 17 15:10:49 localhost kernel: ipw2200: Copyright(c) 2003-2006 Intel Corporation
>> Oct 17 15:10:49 localhost kernel: __l4x_ioremap: Requested region at b8006000 [0x1000 Bytes]
>> Oct 17 15:10:49 localhost kernel: __l4x_ioremap: Mapping physaddr b8006000 [0x1000 Bytes, b8006000+001000] to 
>> 3f58a000+000000
>> Oct 17 15:10:49 localhost kernel: ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
>> Oct 17 15:10:49 localhost kernel: firmware: requesting ipw2200-bss.fw
>> Oct 17 15:11:49 localhost kernel: ipw2200: ipw2200-bss.fw request_firmware failed: Reason -2
>> Oct 17 15:11:49 localhost kernel: ipw2200: Unable to load firmware: -2
>> Oct 17 15:11:49 localhost kernel: ipw2200: failed to register network device
>> Oct 17 15:11:49 localhost kernel: ipw2200: probe of 0000:06:05.0 failed with error -5
>> -- This is from dmesg output. Maybe, I missed something other?
>-2 means 'no such file or directory'?!

I finally got wifi working! The reason was that for some unknown reason /sbin/udevd does not start in L4Linux 
(but in normal linux it does). So, I launched it manually. After that I did "modprobe ipw2200" and it started! -- I read the
README file from Linux kernel sources in Documentation\networking and it mentions that firmware is loaded by udev. 
So, I checked if udev is runnig and the result. Also, for some reason, /sys does not mount, but it is mounted automatically 
in normal linux (I have corresponding /etc/fstab entry) but when I do "mount /sys" it is mounted.

But still X11 complains about not having all I/O privileges.

PS: When I did "modprobe serial_cs" udev created ttyS0..ttyS3 devices but still no comm port access. So, access to video
and comm-ports don't work but network and disks are working. Why could it be?

More information about the l4-hackers mailing list