Problems with l4linux

Valery V. Sedletski _valerius at
Wed Oct 22 07:00:04 CEST 2008

On Tue, 21 Oct 2008 23:53:30 +0200, Adam Lackorzynski wrote:
>> No, I tried this option in loader config file (roottask does not
>> understand such option) and no difference from allow_cli, the same
>> effect: roottask gives all IO ports to loader and loader gives all
>> 65535 ports to l4linux. You can ensure by looking at serial output:
>Ok, good. Looks like I could have screwed it up. Please try to make the
>'#if 0' in arch/l4/kernel/arch-i386/ioport.c into a '#if 1'. That should
>make a difference.

I unmommented the fragment and recompiled, but an error appeared: 

loader  | vmlinuz26: Starting application using
loader  | vmlinuz26,#f: Loading binary
loader  | vmlinuz26,#f: Loading ldso
loader  | vmlinuz26,#f: Starting at 000138e0 via 0000cbe8
l4lx    | ======> L4Linux 2.6 starting... <========
l4lx    | Linux version 2.6.26-l4-svn119-dirty2 (root at localhost) (gcc version 4
l4lx    : .2.2 20071128 (prerelease) (4.2.2-3mdv2008.0)) #5 Wed Oct 22 15:59:47
l4lx    :  PETST 2008
l4lx    | Binary name: vmlinuz26
l4lx    | Linux kernel command line (8 args): mem=100M video=l4fb:refreshsleep:
l4lx    : 200 l4fb.nograb=1 load_ramdisk=1 ramdisk_size=40960 root=/dev/ram l4e
l4lx    : nv_rd=(nd)/tftpboot/drops/ramdisk/drops-fp.rd panicblink=0
l4lx    | Image: 00400000 - 00854000 [4432 KiB].
l4lx    | Areas: Text:     00400000 - 0075d000 [3444kB] (a bit longer)
l4lx    |        Data:     0075d000 - 00782978 [150kB]
l4lx    |        Initdata: 00786000 - 007bb000 [212kB]
l4lx    |        BSS:      007bc000 - 0085393c [606kB]
l4lx    | l4lx_thread_create: Created thread 0f.03 (tamer0)
l4lx    | Tamer0 is 0f.03
l4lx    | Using tamed mode.
ROOT: Sending all ports (for cli/sti) to task #0d
l4lx    | Got 65536 out of 65536 I/O ports
l4lx    | L4RM: unknown exception src=F.02 exc=-5 ip=00405afd data=0,0
con     | vc_loop(): vc[1] running as C.07
con     | vc[1] 800x600 at 16, bpl:1600, gmode:0x25, evprt:E.03 save:0
run     | contxt_init(): 800x582, cols:100, lines:41, sb_lines:1041

>> I finally got wifi working! The reason was that for some unknown reason /sbin/udevd does not start in L4Linux 
>> (but in normal linux it does). So, I launched it manually. After that I did "modprobe ipw2200" and it started! -- I read the
>> README file from Linux kernel sources in Documentation\networking and it mentions that firmware is loaded by udev. 
>> So, I checked if udev is runnig and the result. Also, for some reason, /sys does not mount, but it is mounted automatically 
>> in normal linux (I have corresponding /etc/fstab entry) but when I do "mount /sys" it is mounted.
>I see no reason why it couldn't work, right now because it works for me
>(using Debian).
>> But still X11 complains about not having all I/O privileges.
>> PS: When I did "modprobe serial_cs" udev created ttyS0..ttyS3 devices but still no comm port access. So, access to video
>> and comm-ports don't work but network and disks are working. Why could it be?
>Sorry, no idea with the card. It doesn't say anything strange in dmesg?

Only that serial_cs module prints the message that it could not access high memory. I hope this error disappear after linux will
get I/O privileges

More information about the l4-hackers mailing list