Problems with l4linux

Valery V. Sedletski _valerius at
Mon Nov 10 14:20:20 CET 2008

On Wed, 5 Nov 2008 22:25:19 +0100, Adam Lackorzynski wrote:

>> > The above message would mean that the X server is talking to the
>> > L4Linux-server which is a no-go except the special X driver is used.
>> >
>> I enabled X server stub in L4Linux configuration (a checkbox "Support for X 
>> Window System driver" is enabled). And nitovlwm server is started. What could
>> I miss then?
>This setup is not the easiest one and not easy to setup, it also
>requires quite an effort for me to get this running. I recommend using
>the X 'fbdev' driver which basically just works out of the box. It isn't
>as CPU friendly as it could be but the handling is easy. Using a special
>X driver is better in several ways but requires some care.

Yes, I know that this setup is not easy. For overlay_wm driver to work it is necessary to apply 
patches to X Server sources, as I read. But I thought it must work with linux server with ordinary
l4con/dope frambuffer driver. So, it won't, ok. -- When I checked on real machine (not with ramdisk),
l4linux started and XServer starts OK.

But again the new problem -- with udev. First time for some reason udev didn't started and /sys filesystem
did not mounted (it was some problem with initial ramdisk). When I mounted /sys manually, created all device
nodes manually and started udevd from the command line, almost all worked -- bluetooth, usb, etc. But when
I made initrd properly, I got an error "Kernel panic: not syncing, Out of memory and no killable processes" when
starting udev. I can't copy/paste the boot log as nothing were saved in logs. How can I report this problem?
I can't also redirect output to file as system is not syncing (I booted with init=/bin/sh successfully and then
panic message appears if launch /sbin/start_udev from the command line).

I tried to upgrade udev to the latest version (I have ver. 1.14 and the newest one is 1.30) but no effect. Also I searched
for this error message in google and found a few references to mailing lists where Fedora and Slackware users mentioned
similar problem  -- it was not with udev itself but with latest kernels -- with 2.6.24 this were OK, but with 2.6.25 and later
were these problems. So, I decided to try downgrading l4linux kernel. I tried many revisions from SVN from 2.6.27 down
to 2.6.22 with no success -- Linux was either panicing or handing when starting udev.

And the last, I tried latest linux kernels (2.6.27 and 2.6.28) without L4 -- they boot successfully and don't panic when starting udev.
So, I figured out that this is L4Linux-related problem as in ordinary linux kernels the problem seems to disappear.

So, must I report this as a bug? And what additional information I can give to solve the problem
I have Mandriva 2008.0 distribution installed with linux kernel 2.6.22. It is installed on notebook with 2 Gb of memory and
1.7 Ghz Pentium M (with Centrino) processor. I tried to give linux server 800 to 1800 Mb of memory and tried to play with
initrd size, but with no effect. My notebook has no serial port, so I can't save the log. But I can install linux to my desktop
machine, if needed. It has a serial port and serial cable.


More information about the l4-hackers mailing list