Problems with l4linux

Valery V. Sedletski _valerius at
Fri Nov 14 11:36:31 CET 2008

On Fri, 14 Nov 2008 19:59:19 +1200 (MSK), Valery V. Sedletski wrote:

>On Wed, 12 Nov 2008 23:13:33 +0100, Adam Lackorzynski wrote:

>>I think downgrading Linux is not the way fixing this. Knowing the real
>>reason would be very helpful. Did you try strace e.g.?
>Strace? What is it? Is this a Linux or Fiasco feature? (ok, silly question, I'll
>try googling)

I tried booting with init=/bin/sh and executing "strace /sbin/start_udev" after
manually mounting /sys and /proc. (udevd exits when /sys is not mounted).
It prints a syscall trace, but it get running quickly, and at the end of process 
I get a Kernel panic message with call trace messages which are filling all 
screen and I can't see strace output as I can't scroll screen buffer back by 
Shift-PgUp because linux is dead, Also I tried to redirect strace messages to 
file but filesystems are mounted readonly and can't write files to disk. Also 
when panic occurs, linux doesn't sync files with cache. So, I'm in a spot. :( 
What else can I do?


More information about the l4-hackers mailing list