Problem of running L4Linux

Adam Chang windbread at
Wed Dec 24 10:28:12 CET 2008

Dear all:
    I still have some problem on running L4Linux.
    I have succeeded install your version of GRUB in my VMware virtual
disk. And the following is my menu.lst

title L4Linux-2.6
kernel /common/bootstrap
modaddr 0x02000000
module /common/fiasco -nokdb -serial_esc
module /common/sigma0
module /common/roottask task modname "bmodfs" attached 5 modules
module /common/names
module /common/log
module /common/dm_phys --isa=0x00800000
module /common/simple_ts -t 300
module /common/rtc
module /common/l4io
module /common/bmodfs
 module /common/cfg/l4linux26.cfg
 module /common/
 module /common/
 module /common/vmlinuz
 module /common/drops.rd
module /common/loader --fprov=BMODFS l4linux26.cfg
When I boot the virtual machine, first the machine start fiasco,
sigma0 , roottask
roottask loaded 13 modules,and finally I see these message while I
failed running L4Linux
loader	| vmlinuz: Starting application using
loader	| vmlinuz,#d: Loading binary
loader	| vmlinuz,#d: Loading ldso
loader	| vmlinuz,#d: Starting at 000138e0 via 0000cf40
l4lx	| ======> L4Linux 2.6 starting... <========
l4lx	| Linux version 2.6.27-l4-svn131 (bread at Bread) (
l4lx	| Linux version 2.6.27-l4-svn131 (bread at Bread) (gcc version 4.3.2 20081
l4lx	: 105 (Red Hat 4.3.2-7) (GCC) ) #1 Sat Dec 13 14:15:36 CST 2008
l4lx	| Binary name: vmlinuz
l4lx	| Linux kernel command line (5 args): mem=64M load_ramdisk=1 ramdisk_size
l4lx	: =16384 root=/dev/ram0 l4env_rd=drops.rd
l4lx	| The running microkernel does not have the
l4lx	|       segments
l4lx	| feature enabled!

    --Microkernel feature missing!---------------------------IP: 00636869
[l4lx.main] (d.02) jdb:
And I jumped to the jdb console.

all the step I built L4env and L4linux just followed the document, and
so did my GRUB menu,lst.
And I don't know what's wrong. So can someone give me advice how to
solve this problem?

Best Regards.
Adam Chang

On Fri, Dec 12, 2008 at 5:44 AM, Adam Lackorzynski
<adam at> wrote:
> Hi,
> On Fri Dec 12, 2008 at 02:21:15 +0800, Adam Chang wrote:
>>    I have succeeded in building L4Linux, and then I tried to boot
>> Fiasco and run L4Linux on VMware.When I tried to download your version
>> of GRUB bootloader on SVN, it said "At revision 422", not downloaded
>> something. So where can I download the source code of your version of
>> GRUB bootloader?
> It's available as a patch with a bit of docu at
> Latest version is this one:
>> And is there some documentation of running L4Linux on Fiasco?
> Like this?
> Adam
> --
> Adam                 adam at
>  Lackorzynski
> _______________________________________________
> l4-hackers mailing list
> l4-hackers at

Adam Hung-Hsiang Chang
windbread at
Wireless Networking and Embedded Systems Lab
Graduate Institute of Networking and Multimedia
National Taiwan University

More information about the l4-hackers mailing list