Urgent help needed>> please tell us what menu.lst do we need for usbhid application

Björn Döbel doebel at os.inf.tu-dresden.de
Sun Apr 5 17:30:52 CEST 2009

Hash: SHA1


again, there is no need to double post.

>              We are student of IIT Delhi. We are trying to build a usb
> webcam application and ext2 file system driver on L4.  We have seen an
> *application
> USBHID directory* under L4/pkg downloaded from svn . Could anybody let us
> know how to use this application. Please also let us know the required
> menu.lst file to use this application .

>              1) Please also describe required menu.lst file to use dde,
> dde_linux26, dope, drop,loader together .

You may find our Wiki at http://wiki.tudos.org/Main_Page a useful
resource for some initial reading.

>              2) Could any body tell us what is the difference between dde
> and dde_linux26 application found in svn ?

dde_linux26 (combined with linux-26-headers) is the older version which
is deprecated by the re-implementation found in the dde package.
However, the L4IDE disk driver you might be interested in, relies on
this old version.

>              3) Please also tell us how to use these to build an usb device
> driver.

Depending on what you are trying to learn, you can either
1) build a Linux USB driver, link it against the DDE/Linux libraries and
run it on L4, or
2) build a L4Env device driver based on DDEKit (l4/pkg/dde/ddekit). The
interface is slightly different, but if you know how to do things in
Linux, you'll quickly find that it is basically the same way using DDEKit.

Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the l4-hackers mailing list