Using l4con for ARM integrator

Adam Chang windbread at
Tue Apr 7 09:49:22 CEST 2009

Dear all:
    I tried to run several l4linux on QEMU ARM integrator through
l4con. And I edited the modules.list in /l4/pkg/bootstrap/server/src
I modified "entry dope" to "entry l4con", and add con and run to
modules.list , like the following
modaddr 0x02000000

entry auto-build-entry
kernel   Makefile
sigma0   Makefile
roottask Makefile

entry hello
kernel fiasco -serial_esc -comport 1 -nowait -nokdb -jdb_cmd=JH
bin hello

entry names
bin names

entry log
kernel fiasco -comport 1
bin names
bin log
bin pingpong

entry pingpong
bin pingpong

entry l4con
roottask roottask task modname "loader" boot_priority 0xe3
bin names
bin log
bin dm_phys
bin con
bin vscrtest

entry sharedtest
kernel fiasco -serial -comport 1
bin names
bin log
bin dm_phys -v
bin simple_ts -t 10
bin bmodfs
data  shared_test
bin loader --fprov=BMODFS shared_test

entry l4linux
bin names
bin log
bin dm_phys -v
bin simple_ts -t 10
bin con
bin l4io
bin bmodfs
data  shared_test
data  vmlinuz
data  rd
data  run
data  l4linux.cfg
bin loader --fprov=BMODFS run l4linux.cfg

entry l4vm
kernel   v2/fiasco -noserial -nowait -nokdb -loadcnt
sigma0   v2/sigma0
roottask v2/roottask -configfile
data     cfg/rmgr.cfg
bin      v2/names --events
bin      v2/events
bin      v2/logcon
bin      v2/dm_phys --events
bin      v2/simple_ts --tasks 380 --events --anykill
bin      v2/rtc
bin      v2/l4io --nolist
bin      v2/con --l4io --omega0 --events --cpuload --vbemode 0x117 --pan
bin      v2/loader --events --fprov=BMODFS ldr_run.bmodfs
bin      v2/name_server
bin      v2/l4vfs_log
bin      v2/fstab -c/log -v10 -b/ -m/log
bin      v2/bmodfs
data     v2/
data     v2/
data     cfg/ldr_run.bmodfs
data     v2/run
data     lx/vmlinuz
data     cfg/
data     rd/initrd.gz
But When I run the image, I found that it doesn't go to the run
console, and after entering l4linux, I got some error message.
# run     | l4con/lib/src/contxt.c:63:contxt_init():
run     |  Could not find con at names
run     | main(): Error -3 opening contxt lib -- terminating
run     |
run     | Exiting with -3
simplets| Exit d.02

Can someone give some advise for this problem?
Adam Hung-Hsiang Chang
windbread at
Wireless Networking and Embedded Systems Lab
Graduate Institute of Networking and Multimedia
National Taiwan University

More information about the l4-hackers mailing list