vbeset support for GRUB

Andre Puschmann andre.puschmann at imms.de
Fri Apr 24 10:56:51 CEST 2009

Hi Neohtm,

Neohtm wrote:
> Hi,
> I'm able to compile L4 Fiasco + DOpE + L4Linux and test run on Qemu.
> But when i run it on the real machine, the GRUB seems don't support 
> for modaddr and vbeset command.
Are you sure you are running the right version of grub?
Grub should display a version string like "GNU GRUB  version 0.97-os.7"

> I got the GRUB-0.97 source from Adam's website and compile 
> successfully. But what is the next step after this in order to boot 
> directly on the current machine? I tried to copy directly the compiled 
> files to /boot/grub but it didn't shows the menu.lst
You definitely need to install it first.
Here is a good site that explains the installation process: 

> instead of that, i'm also not sure about how to tftpboot to another 
> machine? any site or instructions on how to achieve this?
There are a lot of howto-site around. Try to google words like "pxegrub 
tftp dhcp". Depending on your distribution you may add words like ubuntu 
or debian.
Basically, you need a dhcp server in order to assign your client an IP 
address and to tell the client where to find the pxegrub binary. Of 
course, you also need a tftpserver to serve the files. Have a look at 
dnsmasq which implements a lightweight dhcp, dns and tftp server.
This one works for me here.

Best regards,


More information about the l4-hackers mailing list