The errors i tried to map iomem to virtual memory

Adam Lackorzynski adam at
Wed Nov 4 00:28:02 CET 2009


On Tue Nov 03, 2009 at 23:37:12 +0800, Guanghui, Cheng wrote:
> 	I tried to map the hpet iomem to the virtual memory but i got some error. The 
> log is as following:
> vtimer  | rmgr_pager 4:0
> vtimer  | hpet_address 0xfed00000
> vtimer  | hpet size 0x400000
> vtimer  | hpet_virt_address 0x400000
> ROOT: Cannot map page at fed00000 log2_size=12 failed
> vtimer  | IOMem mapping error : No fpage received
> vtimer  | __handle_pf(): L4RM: page fault: no entry in region list
> vtimer  | L4RM: [PF] read at 0x00400000, ip 0100024e, src 8.02
> 	It seems that when I map the iomem the pagesize is not permitted but 
> superpagesize is ok.  But i still get the error as "No fpage received". Does 
> anybody tell me what the problem is?

roottask can map non-RAM as superpages only. For getting device memory
you should use and query l4io which can handle this much better. Did you
try that?

Adam                 adam at

More information about the l4-hackers mailing list