The errors i tried to map iomem to virtual memory

Guanghui, Cheng cheng.guanghui.ml at gmail.com
Wed Nov 4 14:11:06 CET 2009


On Wednesday 04 November 2009 07:28:02 Adam Lackorzynski wrote:
> Hi,
>
> On Tue Nov 03, 2009 at 23:37:12 +0800, Guanghui, Cheng wrote:
> > 	I tried to map the hpet iomem to the virtual memory but i got some
> > error. The log is as following:
> > vtimer  | rmgr_pager 4:0
> > vtimer  | hpet_address 0xfed00000
> > vtimer  | hpet size 0x400000
> > vtimer  | hpet_virt_address 0x400000
> > ROOT: Cannot map page at fed00000 log2_size=12 failed
> > vtimer  | IOMem mapping error : No fpage received
> > vtimer  | __handle_pf(): L4RM: page fault: no entry in region list
> > vtimer  | L4RM: [PF] read at 0x00400000, ip 0100024e, src 8.02
> > 	It seems that when I map the iomem the pagesize is not permitted but
> > superpagesize is ok.  But i still get the error as "No fpage received".
> > Does anybody tell me what the problem is?
>
> roottask can map non-RAM as superpages only. For getting device memory
> you should use and query l4io which can handle this much better. Did you
> try that?
Hello, Adam:
	Now i fixed l4io a little and add the hpet device after the tpm device 
in the l4io/server/src/static_cfg_x86.c and now i could map the hpet device
into the virtual device. I could read/write the hpet device directly. This is
a important progress for vtimer server implementation.  If i make more i
could report to you.
	Thanks for your kind remind.
	Best.
							Cheng Guanghui

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20091104/33b26824/attachment.html>


More information about the l4-hackers mailing list