Post Bison version fix error

Harish G. Naik mail at hnaik.net
Thu Apr 1 23:31:57 CEST 2010


So I was advised to download bison 2.3 and install it and use it
instead of the system default 2.4.1.
I did that and I now get a different, much shorter:

c-scanner.ll: In function ‘yy::c_parser::token::yytokentype
clex(yy::c_parser::semantic_type*, yy::location*, c_parser_driver&)’:
c-scanner.ll:523: error: ‘strlen’ was not declared in this scope
make[6]: *** [c-scanner.o] Error 1
make[5]: *** [all-recursive] Error 1
make[4]: *** [all-recursive] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all] Error 2
make: *** [../dice] Error 2

Can someone tell me what I might still be missing?

-Harish




More information about the l4-hackers mailing list