bug report and fixed in the dice compiling

Adam Lackorzynski adam at os.inf.tu-dresden.de
Sun Apr 18 18:21:44 CEST 2010


On Sun Apr 18, 2010 at 10:22:31 +0800, Guanghui, Cheng wrote:
> Hello:
> 	In the ubuntu 9.10 with default bison version 2.4.1 the dice configure
> script failed to check the valid bison version:
> 
> the old one:
> 20627  if test "(" "${1}" = "2" -a "(" "${2}" = "1a" -o "${2}" = "1b" -o
> "${2}" = "2" -o "${2}" = "3" ")" ")"; then
> 20628     dice_bison_version="${1}.${2} (ok)"
> 20629   else
> 20630     dice_bison_version=invalid
> 20631   fi
> 
> this verification is only available for bison version 2.1a, 2.2 and 2.3.
> it will be invalid in the bison 2.4 and later.
> 
> the new one:
>  20626   set `$YACC --version|grep 'GNU Bison'|cut -d ' ' -f 4|sed -e
> 's/\./ /'`
> 20627  if test "(" "${1}" = "2" -a "(" "${2}" = "1a" -o "${2}" = "1b" -o
> "${2}" = "2" -o "${2}" = "3" -o "${2}" = "4" -o "${2}" = "4.1" -o "${2}"
> = "4.2" ")" ")"; then
> 20628     dice_bison_version="${1}.${2} (ok)"
> 20629   else
> 20630     dice_bison_version=invalid

Unfortunately this is not enough:

http://wiki.tudos.org/Dice_IDL_compiler


Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/




More information about the l4-hackers mailing list