Problem with building L4Linux

Adam Lackorzynski adam at os.inf.tu-dresden.de
Tue Dec 7 17:30:51 CET 2010


On Tue Dec 07, 2010 at 16:56:04 +0100, Nuno Santos wrote:
> Thank you very much for your help. It's indeed a problem with
> compiling ocaml. As you suggested, tagging it as 'broken' let's
> compile go through.
> 
> I traced the command that leads to this error (from directory
> /local/
> l4re-snap/l4re-snapshot-2010111519/obj/l4/x86/pkg/ocaml/build/stdlib/
> OBJ-x86_586-l4f):
> 
> $ ocamlopt -g -warn-error A -nostdlib -c -o stream.cmx /local/l4re-snap/l4re-snapshot-2010111519/src/l4/pkg/ocaml/contrib/stdlib/stream.ml
> /tmp/camlasm25fea1.s: Assembler messages:
> /tmp/camlasm25fea1.s:580: Error: junk `lazy_force(%rip)' after
> expression
> /tmp/camlasm25fea1.s:580: Error: suffix or operands invalid for `lea'
> /tmp/camlasm25fea1.s:785: Error: junk `lazy_force(%rip)' after
> expression
> /tmp/camlasm25fea1.s:785: Error: suffix or operands invalid for `lea'
> Assembler error, input left in file /tmp/camlasm25fea1.s
> 
> My version of ocamlopt is 3.10.2, and the distribution is Debian 5.0.6.

Ok, that might be the difference, the version I have installed is
3.11.2.


Thanks,
Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/




More information about the l4-hackers mailing list