Problems booting Pistachio

Ashford Nichols fiffty.element at yahoo.com
Sun Dec 26 23:37:19 CET 2010


I recently built the microkernel and tried to boot it using "qemu" but it doesn't work. qemu just seems to not even seem to recognize the image as a bootable image. I followed the instructions given on the site and everything worked, right up to the point where it doesn't boot. I must say though that I did slightly tweak the steps given on the site to create the image file since the original ones didn't work for me. I am really new to qemu so I don't have the slightest clue as to why this isn't working. If anyone experienced this problem or at least know how to resolve this please help me.
The step I followed in order to create the image follows:
dd if=/dev/zero of=l4-image.img bs=512 count=8640mke2fs l4-image.imgmkdir /media/mount_pointmount -o loop l4-image.img /media/mount_pointmkdir /media/mount_point/bootmkdir /media/mount_point/boot/grubcp -aR grub_stages/* /media/mount_point/boot/grubcp -aR modules/* /media/mount_pointumount /media/mount_point


      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20101226/a8c7cacd/attachment.html>


More information about the l4-hackers mailing list