Issue with building L4RE:multiple definition error

WangKevis forgetfish at hotmail.com
Fri Jan 21 17:36:51 CET 2011



Hi,
  when I was doing the building of L4RE as the building instructions, the follwing problems hit me:

make[4]: Entering directory `/home/kaikai/embedded/obj/tuduos/pkg/lua/interpr/OBJ-x86_586-l4f'
  ... Compiling interpr.o
  ==> Linking lua
/home/kaikai/embedded/obj/tuduos/lib/x86_586/l4f/libl4re-vfs.o.a: In function `__L4_STACK_ADDR__':
(*ABS*+0xb0000000): multiple definition of `__L4_STACK_ADDR__'
/home/kaikai/embedded/obj/tuduos/lib/x86_586/l4f/libl4re-vfs.o.a: In function `__L4_KIP_ADDR__':
(*ABS*+0xaffff000): multiple definition of `__L4_KIP_ADDR__'
make[4]: *** [lua] Error 1
make[4]: Leaving directory `/home/kaikai/embedded/obj/tuduos/pkg/lua/interpr/OBJ-x86_586-l4f'
make[3]: *** [/home/kaikai/embedded/obj/tuduos/pkg/lua/interpr/OBJ-x86_586-l4f] Error 2
make[3]: Leaving directory `/home/kaikai/embedded/mybuild/src/l4/pkg/lua/interpr'
make[2]: *** [interpr] Error 2




                                                                                                                                    王凯凯                                                                                                                                     

 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20110121/555ddcb9/attachment.html>


More information about the l4-hackers mailing list