I cannot for the life of me compile l4linux

Daniel F. Haaland daniel_fairchild.haaland at mailbox.tu-dresden.de
Tue Jan 25 05:38:59 CET 2011


l4re and fiasco seem to be working just fine (tested by running the
hello world in qemu), but trying to add l4linux on top of l4re has
caused me a lot of grief and the following error message:

Getting required compilation flags failed.
L4OBJ: /home/drxl/l4stuff/builddirs/L4Re-R27MP
L4_REQUIRED_MODS: stdlibs log l4re_c-util libio shmc
/home/drxl/l4stuff/src/l4linux/arch/l4/Makefile:301: *** Aborting..  Stop.
make: *** [sub-make] Error 2
zsh: exit 2     make O=$MY_L4LINUX_OBJDIR

I've detailed how I got to that point in painstaking detail here:
http://blog.fairchild.dk/notes/2011/01/25/getting-l4linux-up-and-running/

In short I've begged, bargained and even resorted to shell-foo like:

find . -type f -name 'Makefile' -exec grep -Hn REQUIRE {} \; |\
sed -e 's,\(.*\)\\$,\1,g' -e 's,^.*=\(.*\)$,\1,g' | sed -n 'H;${g;s/\n//gp}'| \
sed -e 's,[ ]*\([^ ]*\),\1\n,g' | sort -u | uniq | xargs -I ® svn update ®

in the l4/pkg dir, to try and fix any unmet dependencies, but to no avail.

So I guess I wouldn't mind a little help at this point.

best regards
Daniel




More information about the l4-hackers mailing list