[L4 on realview Cortex A9] Failing on board check during fiasco bootup

Adam Lackorzynski adam at os.inf.tu-dresden.de
Thu Feb 10 22:34:17 CET 2011


Hi,

On Thu Feb 10, 2011 at 19:44:07 +0530, Naveen Chandrakar wrote:
> I was attempting to run fiasco built for CortexA9/realview-pbx board on
> qemu.
> "qemu-system-arm" version used for this experimentation is "QEMU PC emulator
> version 0.12.5 (qemu-kvm-0.12.5)"
> L4 Code used "l4re-core-2011020417" with hello world example.
> 
> Below are the messages which i got when i tried to run fiasco on qemu - 1st
> set of logs
> I tried to comment the check inside Board_check::check_board() in the hope
> that it might boot up, but later i got crash for qemu (hw mismatch ?) - 2nd
> set of logs

The board-check passes on the real board. If I remember right it didn't
really work as the real board last time I tried but that's some time
ago. Things might have changed, I should retry.
Anyway, any particular reason you want to use that config? 'realview-eb'
should just work fine.



Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/




More information about the l4-hackers mailing list