[L4 on realview Cortex A9] Failing on board check during fiasco bootup

Naveen Chandrakar novino at gmail.com
Tue Feb 15 15:14:29 CET 2011


Dear Adam,

Actually when we tried qemu for running "smp linux", and it ran fine with
"realview-pbx-a9" board with "-smp 4". Where it booted up with 4 core
configuration.
For the same reason we were selected "realview-pbx-a9" board configuration
when doing "make config" for L4 microkernel under the assumption that it
would run. But the board check itself is failing afterwards (for qemu).
If you could recommend any board which can be used for the "multicore
development" it would be great :).

We really liked the documentation and the code support which is available
with fiasco group for the same reason we wanted to have fiasco as our
primary candidate for experimentations. Please let me know if with some
effort we would be able to bring up the multicore microkernel, i might be
able to help out in case some effort is required for the unimplemented part.

Some misc logs for quick reference from smp-linux kernel bootup validating
the pbx-a9 board working fine with -smp configuration.
novino at naveen-linux:~/Downloads$ qemu-system-arm -M realview-pbx-a9 -cpu
cortex-a9 -kernel zImage_multithread -m 256 -smp 4 -nographic
Uncompressing
Linux............................................................................................................................................................................................
done, booting the kernel.
Initializing cgroup subsys cpuset
Linux version 2.6.28-arm2 (root at test) (gcc version 4.2.2) #27 SMP Tue Oct 19
20:37:18 KST 2010
CPU: ARMv7 Processor [410fc090] revision 0 (ARMv7), cr=10c03c7f
CPU: VIPT nonaliasing data cache, VIPT nonaliasing instruction cache
Machine: ARM-RealView PBX
Ignoring unrecognised tag 0x00000000
Memory policy: ECC disabled, Data cache writealloc
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 65024
Kernel command line: root=/dev/ram0 rw initrd=0x800000, 0x80000
console=ttyAMA0 mem=256M
PID hash table entries: 1024 (order: 10, 4096 bytes)
Console: colour dummy device 80x30
Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
Memory: 256MB = 256MB total
Memory: 253568KB available (3380K code, 276K data, 2276K init)
SLUB: Genslabs=12, HWalign=32, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
Calibrating delay loop... 26.16 BogoMIPS (lpj=130816)
Mount-cache hash table entries: 512
CPU: Testing write buffer coherency: ok
Calibrating local timer... 95.59MHz.
L2X0 cache controller enabled
CPU1: Booted secondary processor
Calibrating delay loop... 26.11 BogoMIPS (lpj=130560)
CPU2: Booted secondary processor
Calibrating delay loop... 73.93 BogoMIPS (lpj=369664)
CPU3: Booted secondary processor
Calibrating delay loop... 163.84 BogoMIPS (lpj=819200)
Brought up 4 CPUs
SMP: Total of 4 processors activated (290.04 BogoMIPS).


On Mon, Feb 14, 2011 at 9:05 PM, Adam Lackorzynski <
adam at os.inf.tu-dresden.de> wrote:

> Hi,
>
> On Mon Feb 14, 2011 at 17:46:34 +0530, Naveen Chandrakar wrote:
> > I've tried running realview-eb against L4 kernel built for arm926EJ and
> it
> > runs smoothly without any glitches :)
> > I was trying to run L4 for the smp variant (esp cortex a9 to be precise).
> >
> > As per the qemu documentation
> >
> > "realview-eb" - doesn't support support cortex a9, the one which i needed
> > was with smp more than 1 (2 or 4)
> > { Eg: novino at naveen-linux
> :~/L4/l4re-core-2011020417/src/l4/mybuild-realview-eb-a9/images$
> > qemu-system-arm -M realview-eb -cpu cortex-a9 -kernel bootstrap_hello.elf
> -m
> > 256 -nographic -net nic -net user -smp 4
> > Number of SMP cpus requested (4), exceeds max cpus supported by machine
> > `realview-eb' (1)
> > }
> >
> > However when i try to run any variant of L4 built for cortex a9 i'm
> getting
> > stuck at the time of execution.
>
> I looked a bit closer to that now and I'm afraid to tell that running MP
> on Qemu requires some extra coding work in Qemu itself. The first thing
> is secondary-cpu bootup for non-linux systems which I could fix. But then
> I see that cp15-c7 is completely not implemented which is required for
> VA-PA translations. That's how far I looked into it for now...
>
>
>
>
> Adam
> --
> Adam                 adam at os.inf.tu-dresden.de
>  Lackorzynski         http://os.inf.tu-dresden.de/~adam/
>
> _______________________________________________
> l4-hackers mailing list
> l4-hackers at os.inf.tu-dresden.de
> http://os.inf.tu-dresden.de/mailman/listinfo/l4-hackers
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20110215/2d8beade/attachment.html>


More information about the l4-hackers mailing list