Genode OS framework and kernel-specific features

Valery V. Sedletski _valerius at mail.ru
Mon Mar 7 13:10:26 CET 2011


On Mon, 07 Mar 2011 11:15:00 +0100, Norman Feske wrote:

>Hi Valery,
>
>> Already googled the Linux Framebuffer HOWTO and several articles. It seems that vesafb will not work for me (I have Matrox G400 
card,
>> on which I get a message "Cannot set vga mode, press Enter..." when booting Linux. Also, it supports VESA 2.0, but GRUB sees only 
modes
>> not higher than 800x600). I also found some drivers in ./kernel/drivers/video/matrox, will check them.
>
>what is your incentive to use the fbdev backend of libSDL? Most of the
>time, we are using the Linux version of Genode with X11, which is very
>convenient during development. (for deployment, we would not recommend
>the Linux version) If your graphics card is supported by X11, there is
>no need to fiddle with fbdev drivers of the Linux kernel.
>

I just compiled Genode in console, not in xterm, so I first tried launching Core from there. So, I noticed that it tries to use a framebuffer, so I 
decided that it is intended way to work. Fiasco.UX seems to work from console too, so I decided that it will work likewise :)

>However, from time to time, we have used libSDL directly with fbdev. So
>once you get the Linux driver for your graphics card running, Genode
>should work as expected.
>

Yes, it even worked. I copied the os\config\demo file to build\bin\config, beside the other executables symlinks. I loaded matrox 
framebuffer driver, and then /dev/fb0 appeared. So, I started core and Genode started with a Launchpad! 

But strange. I managed to hurt my Debian Lenny by OS/2 chkdsk (Linux is installed on JFS filesystem, and I forgot to say OS/2 to not 
touch the Linux partition. So, today after some crash, JFS chkdsk is started, and it moved /dev, /bin, /sbin and /usr/bin dirs to lost+found.). 
Then I reinstalled Linux, and after that Genode won't start anymore. Strange, When I start Core, it spawns Init, then I see two lines in the 
screen log:

[init -> launchpad] Could not open file "config"
[init -> launchpad] Could not obtain config file

-- so, it starts init, and init knows that it must start launchpad (from 'config' file, I think), but nevertheless, it says that 'config' could not be 
found! Strange, it did found 'config' before I reinstalled Linux, but now won't. I thought that maybe, it is something wrong with permissions, 
but I made

chmod 777 config
chown root.root config

and tried to start Core as root. Then it won't find 'config' again. What could be wrong? Need I copy the full Core log? 

WBR,
valery





More information about the l4-hackers mailing list