Genode OS framework and kernel-specific features

Norman Feske norman.feske at genode-labs.com
Mon Mar 7 14:48:13 CET 2011


Hello Valery,

> Yes, it even worked. I copied the os\config\demo file to build\bin\config, beside the other executables symlinks. I loaded matrox 
> framebuffer driver, and then /dev/fb0 appeared. So, I started core and Genode started with a Launchpad! 

Please use 'os/config/linux_demo' instead of 'os/config/demo'. You want
to use the SDL-based framebuffer driver, don't you? ;-)

BTW, you may also try doing a 'make run/demo' in your Genode build
directory. The build system should compile and configure everything to
run the default demo (you'll need to install 'expect' though, see:
'http://genode.org/documentation/release-notes/11.02#section-30').

> But strange. I managed to hurt my Debian Lenny by OS/2 chkdsk (Linux is installed on JFS filesystem, and I forgot to say OS/2 to not 
> touch the Linux partition. So, today after some crash, JFS chkdsk is started, and it moved /dev, /bin, /sbin and /usr/bin dirs to lost+found.). 
> Then I reinstalled Linux, and after that Genode won't start anymore. Strange, When I start Core, it spawns Init, then I see two lines in the 
> screen log:
> 
> [init -> launchpad] Could not open file "config"
> [init -> launchpad] Could not obtain config file
> 
> -- so, it starts init, and init knows that it must start launchpad (from 'config' file, I think), but nevertheless, it says that 'config' could not be 
> found! Strange, it did found 'config' before I reinstalled Linux, but now won't. I thought that maybe, it is something wrong with permissions, 
> but I made

The message is actually fine. It shows that init has started 'launchpad'
as instructed by init's config. So the config file is there. Now
launchpad simply complains that there is no sub config for launchpad
(indeed, there isn't). So it will fall back to a builtin default
configuration. That is the normal behaviour. If you want to configure
launchpad, you'll need to add a '<config>' subnode in launchpad's
'<start>' node. You may have a look at 'os/config/nested_config' to see
how to pass configurations to subsystems, and the
'demo/src/app/launchpad/README' for the configuration options for launchpad.

> and tried to start Core as root. Then it won't find 'config' again. What could be wrong? Need I copy the full Core log? 

Running core as root is not needed. It runs fine as plain user-level
process.

Norman

-- 
Dr.-Ing. Norman Feske
Genode Labs

http://www.genode-labs.com · http://genode.org

Genode Labs GmbH · Amtsgericht Dresden · HRB 28424 · Sitz Dresden
Geschäftsführer: Dr.-Ing. Norman Feske, Christian Helmuth




More information about the l4-hackers mailing list