L4Linux - Freescale i.MX51 Bebbage Board - vmlinuz.arm wanted

Siegfried Podesser spodesser at gmx.at
Fri Mar 11 10:53:12 CET 2011


Hello everyone,

I'm just trying since nearly a week to compile L4Linux. But neither the
SVN-copy nor the snapshot (l4re-snapshot-2011022209) compiles at all.

Before I will explain what I've already tried, my main question, can
someone here send me a correct build vmlinuz.arm file ?

What have I already tried:

_'_'_'_'_'_L4 Linux from SVN _'_'_'_'_'_'_'_'
1. checked it out :) -> svn co
http://svn.tudos.org/repos/oc/l4linux/trunk l4linux
2. kernel configuration and building
->  make ARCH=arm mx51_defconfig O=build (or make ARCH=l4 mx51_defconfig
O=build with recopying mx51_defconfig)
->  make ARCH=arm all CROSS_COMPILE=arm-none-linux-gnueabi- O=build

produces in any case a missing .config.all error where I have no idea
how to produce/get it
-->...

make[3]: *** No rule to make target `/.config.all', needed by
`/home/beresford/Work-Repositories/sepia/l4linux/build/Makeconf.l4conf'.  Stop.
make[2]: ***
[/home/beresford/Work-Repositories/sepia/l4linux/build/Makeconf.l4conf]
Error 2
  GEN     /home/beresford/Work-Repositories/sepia/l4linux/build/Makefile
scripts/kconfig/conf --silentoldconfig Kconfig
make[2]: *** No rule to make target `/.config.all', needed by
`/home/beresford/Work-Repositories/sepia/l4linux/build/Makeconf.l4conf'.  Stop.

make[1]: *** [check_linux_config] Error 1
make: *** [sub-make] Error 2


_'_'_'_'_'_L4 Linux from snapshot file _'_'_'_'_'_'_'_'
or with the snapshot in general (means for the existing realview
platform and not for the mx51, just to see if it builds at least)
1. checked it out -> wget
http://os.inf.tu-dresden.de/download/snapshots-oc/l4re-snapshot-2011022209.tar.bz2

2.                         -> wget
http://os.inf.tu-dresden.de/download/ramdisk-arm.rd für die ramdisk.arm
3. then unzipped
4. then I've tried it exactly as Wesley Miaw posted on Jan 4.1.11
with

GCC_PATH_PREFIX=/opt/sourcery-g++-lite/bin/arm-none-linux-gnueabi-
L4ARCH=arm

make setup
  -> selected ARM realview
make
cd obj/l4linux/arm-up
make arm_defconfig
make menuconfig
  -> set L4 build path obj/l4/arm-rv
  -> set cross compile prefix arm-none-linux-gnueabi-
  -> turned on ARM EABI + old EABI binaries options
make

the last step does not build at all:
...
/home/beresford/Work-Repositories/sepia/l4re-snapshot-2011022209/src/l4linux/include/linux/math64.h:51:15:
note: each undeclared identifier is reported only once for each function
it appears in
In file included from
/home/beresford/Work-Repositories/sepia/l4re-snapshot-2011022209/src/l4linux/include/linux/mm_types.h:11:0,
                 from
/home/beresford/Work-Repositories/sepia/l4re-snapshot-2011022209/src/l4linux/include/linux/sched.h:63,
                 from
/home/beresford/Work-Repositories/sepia/l4re-snapshot-2011022209/src/l4linux/arch/l4/kernel/../../arm/kernel/asm-offsets.c:13,
                 from
/home/beresford/Work-Repositories/sepia/l4re-snapshot-2011022209/src/l4linux/arch/l4/kernel/asm-offsets.c:5:
/home/beresford/Work-Repositories/sepia/l4re-snapshot-2011022209/src/l4linux/include/linux/rwsem.h:
At top level:
/home/beresford/Work-Repositories/sepia/l4re-snapshot-2011022209/src/l4linux/include/linux/rwsem.h:22:65:
fatal error: asm/rwsem.h: No such file or directory
compilation terminated.
make[3]: *** [arch/l4/kernel/asm-offsets.s] Error 1
make[2]: *** [prepare0] Error 2
make[1]: *** [sub-make] Error 2
make: *** [all] Error 2



Maybe someone has an idea.

My development platform:
Gentoo Linux 64bit, 2.6.37-rc1, GCC 4.5.2, arm-none-linux-gnueabi-...
version (Sourcery G++ Lite 2010.09-50) 4.5.1

Thank you :)
siegfried






More information about the l4-hackers mailing list