L4Linux - Freescale i.MX51 Bebbage Board - vmlinuz.arm wanted

Adam Lackorzynski adam at os.inf.tu-dresden.de
Fri Mar 11 22:00:54 CET 2011


Hi,

On Fri Mar 11, 2011 at 10:53:12 +0100, Siegfried Podesser wrote:
> I'm just trying since nearly a week to compile L4Linux. But neither the
> SVN-copy nor the snapshot (l4re-snapshot-2011022209) compiles at all.
> 
> Before I will explain what I've already tried, my main question, can
> someone here send me a correct build vmlinuz.arm file ?
> 
> What have I already tried:
> 
> _'_'_'_'_'_L4 Linux from SVN _'_'_'_'_'_'_'_'
> 1. checked it out :) -> svn co
> http://svn.tudos.org/repos/oc/l4linux/trunk l4linux
> 2. kernel configuration and building
> ->  make ARCH=arm mx51_defconfig O=build (or make ARCH=l4 mx51_defconfig
> O=build with recopying mx51_defconfig)
> ->  make ARCH=arm all CROSS_COMPILE=arm-none-linux-gnueabi- O=build

The L4Linux build defaults to the 'l4' architecture, i.e. an explicit
'ARCH=l4' is not required. Also, it defaults to build for x86, and thus
requires to select ARM explicitly: L4ARCH=arm. So a make call for
configuring looks like this:
  $ mkdir build
  $ make L4ARCH=arm CROSS_COMPILE=arm-none-linux-gnueabi- O=build arm_defconfig 
Before proceeding you need to set the path to your L4 build directory
against which you want to build this L4Linux. This option is the first
one in the L4Linux submenu.
  $ cd build
  $ make L4ARCH=arm CROSS_COMPILE=arm-none-linux-gnueabi- menuconfig
When the path is set, a build should run through:
  $ make L4ARCH=arm CROSS_COMPILE=arm-none-linux-gnueabi-

There aren't any platform specific L4Linux versions, as the platform is
always the same. Passing through (platform specific) devices is
basically not affected by this.


> _'_'_'_'_'_L4 Linux from snapshot file _'_'_'_'_'_'_'_'
> or with the snapshot in general (means for the existing realview
> platform and not for the mx51, just to see if it builds at least)
> 1. checked it out -> wget
> http://os.inf.tu-dresden.de/download/snapshots-oc/l4re-snapshot-2011022209.tar.bz2
> 
> 2.                         -> wget
> http://os.inf.tu-dresden.de/download/ramdisk-arm.rd für die ramdisk.arm
> 3. then unzipped
> 4. then I've tried it exactly as Wesley Miaw posted on Jan 4.1.11
> with
> 
> GCC_PATH_PREFIX=/opt/sourcery-g++-lite/bin/arm-none-linux-gnueabi-
> L4ARCH=arm
> 
> make setup
>   -> selected ARM realview
> make
> cd obj/l4linux/arm-up
> make arm_defconfig
> make menuconfig
>   -> set L4 build path obj/l4/arm-rv
>   -> set cross compile prefix arm-none-linux-gnueabi-
>   -> turned on ARM EABI + old EABI binaries options
> make
> 
> the last step does not build at all:

In the above steps you mean that you did this by hand? If you just let
the 'make setup' configure everything and call make, does it work then?
Also, it should be 'make L4ARCH=arm' for the last make call.

> Maybe someone has an idea.
> My development platform:
> Gentoo Linux 64bit, 2.6.37-rc1, GCC 4.5.2, arm-none-linux-gnueabi-...
> version (Sourcery G++ Lite 2010.09-50) 4.5.1


Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/




More information about the l4-hackers mailing list