crash: l4linux with virtual PCI bus enabled

Adam Lackorzynski adam at os.inf.tu-dresden.de
Thu Jun 16 23:08:36 CEST 2011


On Thu Jun 16, 2011 at 11:29:14 +0200, Arno Toell wrote:
> On 15.06.2011 23:36, Adam Lackorzynski wrote:
> > Could you try another boot method, like grub1iso and see if that works
> > better?
> 
> I tried that right now. Unfortunately it doesn't change anything with
> respect to my problem. Moreover I tried to emulate other PCI network
> devices Qemu is offering (rtl8139), they all have the same problem.
> 
> For what its worth it should be noted, the kernel panic does not occur
> immediately. I can successfully establish network connectivity,
> sometimes even boot the Debian Squeeze on the remote root file system,
> but suddenly it crashes with the very same problem.
> 
> I do run the whole setup in a virtual machine by the way (yes, some
> crazy nested virtualization). If you care enough I could eventually
> provide you - or anyone else - the Virtualbox image, as it exists solely
> to run L4 and has nothing I'd like to keep private in it.

First I'd like to see this happening in another environment. The ISO
image would be enough to look at or try out. You run Linux in VB for
compilation and QEmu etc?


Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/




More information about the l4-hackers mailing list