l4re-snapshot-2011081207 and l4android for arm: build error after update

Adam Lackorzynski adam at os.inf.tu-dresden.de
Wed Aug 24 16:48:57 CEST 2011


Hi,

On Mon Aug 22, 2011 at 11:01:55 +0200, giowck wrote:
> I downloaded the latest l4re snapshot (l4re-snapshot-2011081207), in order
> to compile it along with l4android for arm.
> Finally it compiles with the CodeSourcery cross compiler (as noted in the
> README file), where the previous snapshot failed and worked only for me with
> the 4.2-arm-softfloat compiler (without EABI support).
> 
> But, with the latest snapshot I get a new error:
> 
> # make L4ARCH=arm CROSS_COMPILE=arm-linux- -j4
> make -C /home/wicklein/tests/l4android/kernel
> O=/home/wicklein/tests/l4android/l4android_builddir/.
> Package l4re-main was not found in the pkg-config search path.
> Perhaps you should add the directory containing `l4re-main.pc'
> to the PKG_CONFIG_PATH environment variable
> No package 'l4re-main' found
> Getting required compilation flags failed.
> L4OBJ: /home/wicklein/tests/l4re-snapshot-latest/obj/l4/arm-beagleboard
> L4_REQUIRED_MODS: l4re-main libc_be_minimal_log_io libc_minimal
> libsupc++_minimal log l4re_c-util libio libvcpu shmc
> /home/wicklein/tests/l4android/kernel/arch/l4/Makefile:315: *** Aborting..
>  Schluss.
> make[1]: *** [sub-make] Fehler 2
> make: *** [all] Fehler 2
> 
> Just wanted to report that. Now I'll try to copy just the l4re-main.pc file
> from the old snapshot to the new pc directory.

l4re-main has been removed in the latest version. For l4android, please
use r36 until the l4android repo has been updated to the r38 version.
Anyway, when your solutions works it's also ok.



Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/




More information about the l4-hackers mailing list