L4Re/L4Android specify RAM size on Beagleboard

giowck giowckln at googlemail.com
Wed Sep 7 09:01:16 CEST 2011


Hi,

when running L4Linux/L4Android on the Beagleboard (rev. C4), only 128MB of
256MB RAM are detected by the bootstrap process.

Here [1] you write that the older Beagleboard has only 128MB, so this is
default setting.

As described in that thread, I tried to create the Makeconf.boot file, and it
works so far (image is build with 256MB RAM),
but still only 128MB are actualy detected (limited by scan):

L4 Bootstrapper
 Build: #30 Di 6. Sep 14:38:47 CEST 2011, 4.5.1
 Scanning up to 256 MB RAM
 Memory size is 128MB (Limited by Scan) (80000000 - 88000000)
 RAM: 0000000080000000 - 0000000087ffffff: 131072kB
 Total RAM: 128MB

Please see [2] for the full bootstrap log.

I already tried to adjust manually the support.h and startup.cc file in the
src/l4/pkg/bootstrap/server/src directory, resulting
exactly the same issue.

By the way, I think this is causing L4Android to fail during boot, since memory
is not correctly allocated:

android | l4x_setup_memory: Can't get main memory of 256MB!
MOE: mem_alloc: quota: limit=-1 Byte, used=11572080 Byte
MOE: mem_alloc: global: avail=57008128 Byte
android | Terminating L4Linux.
mag     | GC: step this=0x108d220 _life = 0x13228
mag     | GC: object=0x13228


Thank you for your help so far!

Regards
Giorgio

[1] http://os.inf.tu-dresden.de/pipermail/l4-hackers/2011/004773.html
[2] http://pastebin.com/nHQYGz6s





More information about the l4-hackers mailing list