L4Re/L4Android specify RAM size on Beagleboard

Adam Lackorzynski adam at os.inf.tu-dresden.de
Thu Sep 8 23:50:42 CEST 2011


Hi,

On Wed Sep 07, 2011 at 09:01:16 +0200, giowck wrote:
> when running L4Linux/L4Android on the Beagleboard (rev. C4), only 128MB of
> 256MB RAM are detected by the bootstrap process.
> 
> Here [1] you write that the older Beagleboard has only 128MB, so this is
> default setting.
> 
> As described in that thread, I tried to create the Makeconf.boot file, and it
> works so far (image is build with 256MB RAM),
> but still only 128MB are actualy detected (limited by scan):

I suppose u-boot is saying 256MB?

> L4 Bootstrapper
>  Build: #30 Di 6. Sep 14:38:47 CEST 2011, 4.5.1
>  Scanning up to 256 MB RAM
>  Memory size is 128MB (Limited by Scan) (80000000 - 88000000)
>  RAM: 0000000080000000 - 0000000087ffffff: 131072kB
>  Total RAM: 128MB
> 
> Please see [2] for the full bootstrap log.
> 
> I already tried to adjust manually the support.h and startup.cc file in the
> src/l4/pkg/bootstrap/server/src directory, resulting
> exactly the same issue.

What did you change? You removed the scan-function and hard-coded 256?
 
> By the way, I think this is causing L4Android to fail during boot, since memory
> is not correctly allocated:
> android | l4x_setup_memory: Can't get main memory of 256MB!

Even if the overall system would have 256MB of RAM, how could a single
program/VM alone get that amount?



Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/




More information about the l4-hackers mailing list