L4Android/L4Linux Beagleboard framebuffer and driver

giowck giowckln at googlemail.com
Tue Sep 20 13:52:47 CEST 2011


Hi,

L4Android is booting up and running on my BeagleBoard (rev. C4),
although in command line mode only. So it would be nice getting even the
framebuffer to work, in order to see the Android GUI over video output.

As it is now, the framebuffer seems loading at boot time, but I don't 
get any video output from HDMI/DVI neither from the touchscreen 
(Beagletouch from Liquidware). Please see [1] for the bootstrap log.

Maybe this is due the missing drivers in the kernel, since when 
configuring (ie. menuconfig) the l4android kernel, I see 'System type' 
pointing to 'L4Linux', but some OMAP3 related drivers are only visible 
and thus available, when 'TI_OMAP' is selected in the 'System type' 
config parameter.

Is there a way to build Linux for L4 as target, but including OMAP3 
(video/multimedia) drivers?

I did not found any docs on this topic.

Is it possible to load linux drivers without having to modify the 
underlying parts (fiasco/L4Re)? I mean do I have to add something to my 
omap3.devs file, or are the linux driver able to interact directly with 
the hardware on board?

So far, you can see my arm-omap3.devs file here [2].
Am I missing something important in that device file? Since I copied it 
from the original L4Re source directory.

Thanks,
Giorgio


[1] Bootstrap - http://pastebin.com/GwvN9W6e
[2] devs file - http://pastebin.com/Aq4xt58i
[3] vbus file - http://pastebin.com/cmxEZJyb
[4] cfg  file - http://pastebin.com/qdYzyRcd




More information about the l4-hackers mailing list