Problem booting L4 on Sheevaplug

Adam Lackorzynski adam at os.inf.tu-dresden.de
Tue Nov 8 23:31:26 CET 2011


On Tue Nov 08, 2011 at 11:40:35 +0100, Julian Vetter wrote:
> "make image E=L4Linux-arm BOOTSTRAP_DO_UIMAGE=y
> SUPPORT_CC_armkirkwood=y
> MODULE_SEARCH_PATH=/opt/arm/fiasco:/opt/src/l4/conf/examples:/opt/arm/l4linux:/tmp"
> 
> Everything worked fine. Than I copied the image to my usb stick and
> tried to boot it on the Sheevaplug with UBoot. I got the following output:
> 
> Marvell>> usb start
> Marvell>> fatload usb 0:1 0x00800000 /bootstrap_l4linux-arm.uimage
> 
> Marvell>> bootm 0x00800000
> ## Booting image at 00800000 ...
>    Image Name:   L4 Image #11
>    Created:      2011-11-08  10:20:15 UTC
>    Image Type:   ARM Linux Kernel Image (uncompressed)
>    Data Size:    8028328 Bytes =  7.7 MB
>    Load Address: 01000000
>    Entry Point:  01000000
>    Verifying Checksum ... OK
> OK
> 
> Starting kernel ...
> 
> 
> And then nothing happens after that. I also tried the simple
> 'Hello'-Example without L4Linux, and it also didn't work. Or at least
> I get nothing to see...
> 
> I think the problem is the serial console. But how can I tell L4 that
> the output should be send to this same console? (I'm connected to the
> Sheevaplug via MiniUsb->Usb 'screen /dev/ttyUSB0 115200').

The UART is probably just different. Can you send me an output of a
Linux boot?



Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/




More information about the l4-hackers mailing list