Touchscreen

Wajidali Whowe whowe123 at yahoo.com
Tue Nov 13 21:17:16 CET 2012


Hi Matthias, 

Somehow, the proc file is not mounted when the linux starts and interestingly choosing console = ttyLvx results in a panic case, therefore I have been working on qemu and console was ttyLv0 in my case. Unfortunately lsusb is not supported by the ramdisk I downloaded (drops-rd.rd, this one is from http://os.inf.tu-dresden.de/L4/LinuxOnL4/download.shtml#ramdisk ) Once I mount the proc and then the lspci result is:

00:00.0 IDE interface: Intel Corp. 82371SB PIIX3 IDE [Natoma/Triton II]
00:01.0 USB Controller: Intel Corp. 82371SB PIIX3 USB [Natoma/Triton II] (rev 01)
00:02.0 Ethernet controller: Intel Corp.: Unknown device 100e (rev 03)

However, an ifconfig -a shows only lo interface (i.e., the ethernet interface does not exists) and unfortunately USB keyboard or mouse does still not work in the real hardware... 

here is the final lua script:

""""""""""""""""""""""""""""""""""""""""""""""""

hid = l:new_channel(); 

local linux_caps = {
  log = L4.Env.log:m("rws");
vbus = io_caps.linux_bus,
  rtc = rtc_caps.rtc,
  ev = hid:svr(),
  rom = L4.Env.rom,
};

L4.default_loader:start(
        {
                caps = linux_caps,
        },
        "rom/vmlinuz mem=256M console=ttyLv0 root=1:0 ramdisk_size=32768 l4x_rd=rom/drops-rd.rd init=/bin/sh");


local mag_caps = {
mag = l:new_channel(),
svc = l:new_channel(),
};

l:start({
          caps = {
    vbus = io_caps.con_bus,
    fb   = fb_caps.fb,
    mag  = mag_caps.mag:svr(),
    svc  = mag_caps.svc:svr(),
  },
  ev    = hid, 
          log      = { "mag", "g" },
  l4re_dbg = L4.Dbg.Warn,
        },
"rom/mag");

""""""""""""""""""""""""""""""""""""""""

Best Regards,




________________________________
 From: Matthias Lange <mlange at sec.t-labs.tu-berlin.de>
To: Wajidali Whowe <whowe123 at yahoo.com> 
Cc: "l4-hackers at os.inf.tu-dresden.de" <l4-hackers at os.inf.tu-dresden.de> 
Sent: Monday, November 12, 2012 4:21 AM
Subject: Re: Touchscreen
 

On 08.11.2012, at 19:08, Wajidali Whowe wrote:

Hi Matthias, 
>now the lua script is like this and I just added one additional linux to see whether it is working, however, still I have no usb support:

Does L4Linux shows any signs of USB during boot? What's the output of lsusb?

Matthias.


-- 
Dipl.-Inf. Matthias Lange <mlange at sec.t-labs.tu-berlin.de>
Security in Telecommunications
TU Berlin / Deutsche Telekom Laboratories
Ernst-Reuter-Platz 7, 10587 Berlin
Phone: +49 - 30 - 8353 58 553
Mobile: +49 - 160 - 587 28 07
Web: http://www.fgsect.de 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20121113/6023458e/attachment.html>


More information about the l4-hackers mailing list