Touchscreen

Wajidali Whowe whowe123 at yahoo.com
Thu Nov 15 11:32:39 CET 2012


Dear Adam, 

thanks for the reply, but I thought that the vmlinuz is not allowed to reach io ports and hardware as it is not allowed by fiasco. That is the reason why the io ist started with the following part... Once I use the "use pci" option for the vmlinuz, then I might see the USB devices and so on (through the io), on the contrary if I deactivate the "use pci" option and remove io related part from the lua script, which gives the opportunity to comment out the vbus option, then the kernel might not be booted and I get always Invalide IO access error during boot up... Should I deactivate "Enable I/O port protection" by the fiasco? 

local io_caps = {
  sigma0 = L4.cast(L4.Proto.Factory, L4.Env.sigma0):create(L4.Proto.Sigma0);
  rtc = l:new_channel():svr();
  con_bus = L4.default_loader:new_channel():svr();
  linux_bus = L4.default_loader:new_channel():svr();
  fb = L4.default_loader:new_channel():svr();
  rom = L4.Env.rom;
  icu = L4.Env.icu;
};

L4.default_loader:startv(
  {
    caps = io_caps,
    log = { "io", "red" },
  },
  "rom/io", "rom/x86-legacy.devs", "rom/l4_linux-x86.vbus");





________________________________
 From: Adam Lackorzynski <adam at os.inf.tu-dresden.de>
To: l4-hackers at os.inf.tu-dresden.de 
Sent: Wednesday, November 14, 2012 8:12 PM
Subject: Re: Touchscreen
 

Just adding some bits to what Matthias already wrote.

On Tue Nov 13, 2012 at 12:17:16 -0800, Wajidali Whowe wrote:
> Somehow, the proc file is not mounted when the linux starts and
> interestingly choosing console = ttyLvx results in a panic case,
> therefore I have been working on qemu and console was ttyLv0 in my
> case. Unfortunately lsusb is not supported by the ramdisk I downloaded
> (drops-rd.rd, this one is
> from http://os.inf.tu-dresden.de/L4/LinuxOnL4/download.shtml#ramdisk ) Once
> I mount the proc and then the lspci result is:
> 
> 00:00.0 IDE interface: Intel Corp. 82371SB PIIX3 IDE [Natoma/Triton II]
> 00:01.0 USB Controller: Intel Corp. 82371SB PIIX3 USB [Natoma/Triton II] (rev 01)
> 00:02.0 Ethernet controller: Intel Corp.: Unknown device 100e (rev 03)
> 
> However, an ifconfig -a shows only lo interface (i.e., the ethernet
> interface does not exists)

My guess would be a missing e100 driver in L4Linux

> and unfortunately USB keyboard or mouse
> does still not work in the real hardware... 
> 
> here is the final lua script:
> 
> """"""""""""""""""""""""""""""""""""""""""""""""
> 
> hid = l:new_channel(); 
> 
> local linux_caps = {
>   log = L4.Env.log:m("rws");
> vbus = io_caps.linux_bus,
>   rtc = rtc_caps.rtc,
>   ev = hid:svr(),
>   rom = L4.Env.rom,
> };
> 
> L4.default_loader:start(
>         {
>                 caps = linux_caps,
>         },
>         "rom/vmlinuz mem=256M console=ttyLv0 root=1:0 ramdisk_size=32768 l4x_rd=rom/drops-rd.rd init=/bin/sh");
> 
> 
> local mag_caps = {
> mag = l:new_channel(),
> svc = l:new_channel(),
> };
> 
> l:start({
>           caps = {
>     vbus = io_caps.con_bus,
>     fb   = fb_caps.fb,
>     mag  = mag_caps.mag:svr(),
>     svc  = mag_caps.svc:svr(),
>   },
>   ev    = hid, 
>           log      = { "mag", "g" },
>   l4re_dbg = L4.Dbg.Warn,
>         },
> "rom/mag");

'ev' needs to go into the 'caps' block. Also remove the vbus, you'd only
need it for input device access which is routed via Linux in your setup.



Adam
-- 
Adam                adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/

_______________________________________________
l4-hackers mailing list
l4-hackers at os.inf.tu-dresden.de
http://os.inf.tu-dresden.de/mailman/listinfo/l4-hackers
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20121115/6ef16467/attachment.html>


More information about the l4-hackers mailing list