L4Linux direct access

Riccardo Cecolin l4 at rikiji.de
Thu Feb 9 11:23:27 CET 2012

I had to disable the "use vCPU execution model" to get that output. I added
console=ttyLv0 and enabled support for it into the l4linux config, then
with bash as init i could see  "allow_cli: allow_cli: No such file or
directory" in the log.
So i removed it from the command line and now i get a working bash! After
mounting /proc lspci works fine too.

When trying with the default init i never get the login prompt, it freezes
after "No user config loaded!", so something is still wrong (this with
If i load the other root image with an rc.local which executes "startx" i
get the following error: xf86EnableIOPorts: failed to set IOPL for I/O
(Operation not permitted). A previous mail in this list states that this is
solved with that "allow_cli" parameter, but I need now some advice about
where to put it, assuming that it is still a valid solution.

Thank you for your help.

On Wed, Feb 8, 2012 at 1:40 PM, Adam Lackorzynski <adam at os.inf.tu-dresden.de
> wrote:

> Hi,
> On Tue Feb 07, 2012 at 11:28:12 +0100, Riccardo Cecolin wrote:
> > I tried with the drops-rd.rd filesystem image found here:
> > http://os.inf.tu-dresden.de/L4/LinuxOnL4/download/drops-rd.rd and with a
> > debootstrap generated one of debian stable and they both hang there. The
> > same images work fine if I boot l4linux with fbdrv and mag.  Everything
> 32
> > bit, bash is dynamically linked on the drops image as well as on the one
> i
> > created. Libraries are in their place and /dev/console is there.
> > If instead of /bin/bash i let the default init process start I get a
> > segfault at 405f24 (dispatch.c) and then repeated segfaults in 4109d5
> > (where i suppose it is trying to dump the stack).
> The way the output works should not make a difference here in this
> regard, so hmm. Could you add console=ttyLv0 to Linux cmdline to get
> more output on the serial?
> > I have been able to see this output poking with the VCPU option in the
> > l4linux advanced configuration.
> With it on or off?
> Adam
> --
> Adam                 adam at os.inf.tu-dresden.de
>  Lackorzynski         http://os.inf.tu-dresden.de/~adam/
> _______________________________________________
> l4-hackers mailing list
> l4-hackers at os.inf.tu-dresden.de
> http://os.inf.tu-dresden.de/mailman/listinfo/l4-hackers
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20120209/1d339cfc/attachment.htm>

More information about the l4-hackers mailing list