l4linux GPU direct access

Adam Lackorzynski adam at os.inf.tu-dresden.de
Tue Jul 3 22:00:56 CEST 2012


On Tue Jul 03, 2012 at 11:45:08 +0200, Abhishek Gupta wrote:
> I have checked the xserver code and found that the DEFAULT_INT10 was already
> set to x86emu and it was already using x86emu to execute the int10.
> Also, there is one more mode vm86 in which int10 can be executed but it uses
> the vm86 system call which is not supported in l4linux.
> Is there a way to add vm86 system call to the l4linux?

No way. Using x86emu is just the way to execute this code, and that a
vm86 mode exists on x86 is just luck (to put it this way).

> Also, I have tried with video drivers cirrus, qxl but none of them worked.
> I tried Ubuntu on vmware player and it uses vmware video driver to run
> xserver and does not uses int10.

I wonder why you can't let fbdrv init to VESA and still access the
graphics card for acceleration. Or do you absolutely need to do the
initialization yourself?

Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/

More information about the l4-hackers mailing list