Problem Booting x86_64 kernel in qemu

Markus Pfeiffer markus.pfeiffer at
Thu Aug 9 15:50:25 CEST 2012

Dear Adam,

On Thu, Aug 09, 2012 at 03:33:16PM +0200, Adam Lackorzynski wrote:
> Hi,
> On Wed Aug 08, 2012 at 11:35:20 +0000, Markus Pfeiffer wrote:
> > I tried building the Fiasco kernel (x86_64, from svn) together with the hello demo
> > inside a qemu as it is shown on the website under "Getting started".
> > 
> > Unfortunately the kernel traps while booting (Unexpected trap while booting
> > Fiasco). The trap number seems to be invalid (-8029759185026510704). Any
> > pointers towards where to look for a fix?
> Works for me. The website uses 32 bit Qemu ('qemu'), did you use
> qemu-system-x86_64?

Yes, I am running on archlinux 64 bit, I also tried qemu alone and different
options for -cpu and -machine.
GCC version is 4.7.1 and qemu version is 1.1.1.

I tried narrowing the problem down and found that the problem seems to be that
Cpu::boot_cpu() returns NULL in kernel_main in  main-ia32-64.cpp,
So I would suspect that this is due to some weird thing in the build
toolchain going wrong and not calling the constructors of Cpu or Per_cpu

(Disclaimer, I have only been reading this code for a few hours, so I by no
means know whether this is actually the cause).

Markus Pfeiffer, University of St Andrews
email: markus.pfeiffer at | xmpp: markus.pfeiffer at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 834 bytes
Desc: not available
URL: <>

More information about the l4-hackers mailing list