Problem Booting x86_64 kernel in qemu

Markus Pfeiffer markus.pfeiffer at
Sun Aug 12 16:55:52 CEST 2012

Hello again

On Fri, Aug 10, 2012 at 11:16:07PM +0200, Adam Lackorzynski wrote:
> I just tried it with a recent post 4.7.1 build (4.7.2) and it worked.
> Could you try a different gcc to check this possiblity (e.g. some other
> distribution in a chroot)?

So, I built the kernel on gcc-4.7.0 from pkgsrc on DragonFly, and lo and
behold the kernel seems to work (at least it boots) and then page faults later
while running the hello application, this might be something entirely
different now, and I might have to investigate what could have gone wrong.
(DragonFly build of the svn version fails because of -nostdinc and stddef.h
includes sys/types.h, so I just added /usr/include again which might have
caused a mess)

No fpage received
MOE: cmdline: moe rom/hello.cfg
MOE: Starting: rom/ned rom/hello.cfg
MOE: loading 'rom/ned'
L4Re[rm]: unhandled read page fault @0 pc=1044b9e
L4Re: unhandled exception: pc=0x1044b9e

Thanks for the help so far. As soon as ArchLinux updates their gcc I will try
again and try to find out whether there's something funny going on with
ArchLinux' multilib compiler.


Markus Pfeiffer, University of St Andrews
email: markus.pfeiffer at | xmpp: markus.pfeiffer at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 834 bytes
Desc: not available
URL: <>

More information about the l4-hackers mailing list