Fiasco.OC (rev. 40) Pandaboard support

Alexander Warg alexander.warg at
Fri Sep 7 15:32:36 CEST 2012

On Fri, 2012-09-07 at 14:39 +0200, Stefan Kalkowski wrote:
> Hi L4-hackers,
> recently I've tried to adapt Genode's Fiasco.OC-platform support to use
> the latest Fiasco.OC/L4Re subversion revision. When trying it on x86 I
> didn't run into any trouble. It worked "out of the box".
> But when it came to ARM, I got problems to boot Fiasco.OC on the
> Pandaboard in general (also when using plain Fiasco.OC/L4Re).
> I've debugged the problem down to Cpu::init_errata_workarounds(). The
> problem is that pandaboard's boot code initializes TrustZone, and
> triggers a configuration-disable signal beforehand. That leads to
> 'undefined instruction' exceptions, whenever one tries to write into the
> p15/c15-c0-1 debug register (like it's done in init_errata_workarounds).
> The attached patch implements Cpu::init_errata_workarounds() empty for
> the pandaboard. Moreover, it restricts the appliance of ERRATA 743622 to
> CPU revisions: r2p0-r2p2.
> With the attached patch Fiasco.OC runs fine on the Pandaboard too.

See messages from 18/08/12: Re: Issues in l4re-snapshot-2012081219 for


More information about the l4-hackers mailing list