Page Fault on real hardware

Wajidali Whowe whowe123 at
Wed Oct 31 00:27:35 CET 2012

Dear Guys, 

I tried a clean l4 linux and updated all corresponding packages and now there is no problem anymore... I thank you very much for your valuable time...

Best Regards,

 From: Adam Lackorzynski <adam at>
To: l4-hackers at 
Sent: Monday, October 29, 2012 11:37 PM
Subject: Re: Page Fault on real hardware
On Mon Oct 29, 2012 at 09:54:40 -0700, Wajidali Whowe wrote:
> I also tried the  x86-mp_vPCI_defconfig and x86-native_defconfig (For
> both of them I only deactivated PMEM support) and now they resulted in
> the following outputs, where the PC might also not be seen, i.e. there
> is no page fault but the Trap 13: 
>  ..
>  ..
>  vmlinuz . | main thread will be 414
>  vmlinuz . | l4x_register_pointer_section: addr = 006a8000 size = 2072576
>  vmlinuz . | section-with-init: virt: 0x6a8000 to 0x8a1fff [2024KiB]
>  vmlinuz . | section-with-init: Phys: ....
>  ..
>  ..
> vmlinuz . | Loading: rom/ramdiskfs.tar.gz 
> vmlinuz . | INITRD: Size of RAMdisk is 32768KiB
> vmlinuz . | RAMdisk from 18c000000 to 1ac00000 [32768KiB] 
> Die message: Trap: 13
> vmlinuz . | panic: going to sleep forever, bye
> Would it be possible to find out the specific definitions for the
> Traps? For instance does Trap number (in our case 13) tell about the
> reasons? 

General protection fault is basically a catch-all thing and can have a
couple of many reasons. The next thing to try it is to add
earlyprintk=1 to the linux kernel command line and make sure that
CONFIG_EARLY_PRINTK is enabled in the kernel. Additionally you may put
vmlinux somewhere online (build with CONFIG_DEBUG_INFO) for me to have a
look at.

> I tried for objdump and searching for "47356" not "473569", I found the following output: 
> 00047350 <rcu_barrier_bh>:
>    47350:       55                      push   %ebp
>    47351:       ba 84 4e 02 00          mov    $0x24e84,%edx
>    47356:       89 e5                   mov    %esp,%ebp
>    47358:       83 ec 14                sub    $0x14,%esp
>    4735b:       8d 45 f8                lea    -0x8(%ebp),%eax
> I guess that this is related with the RCU and i tried different options for the RCU by changing Processor related options like PREEMPT etc... However, could not succeed in passing through the RCU system, each time different errors show up. 
> Would it be possible to completely remove the RCU system? do you have a tip on this? Because I could not unfortunately disable it... 

I think this is a dead end, if the IP is 6-digit, why look for something
5-digit long?

Adam                adam at

l4-hackers mailing list
l4-hackers at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the l4-hackers mailing list