NOVA, NUL, snapshotting

Julian Stecklina jsteckli at
Thu Jan 9 17:53:56 CET 2014

On 01/09/2014 04:48 PM, Sartakov A. Vasily wrote:
> 09 янв. 2014 г., в 16:46, Julian Stecklina <jsteckli at> написал(а):
>> On 01/09/2014 04:43 PM, Sartakov A. Vasily wrote:
>>> Hi again
>>> According to my "ps aux" I see two getty with ttyS0 and ttyS1. 
>>> Moreover I see /dev/issue welcome messages in my serial console but I still can’t write anythings, looks like console gives output only. 
>>> I have tried with pty/udp/telnet on qemu side - all the same, only output. 
>> I am confused. Are you asking about Qemu or NUL/Vancouver?
> I’m using nested virtualization. I run NOVA/NUL inside QEMU

I am not sure whether we have ever implemented serial input to VMs.
Serial was mostly used to debug NOVA/NUL.

How did you configure NUL?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the l4-hackers mailing list