Library dependencies missing: stdlibs in directory

Adam Lackorzynski adam at
Mon Feb 10 22:28:35 CET 2014

On Sat Feb 08, 2014 at 20:05:41 +0100, Emanuel Berg wrote:
> I tried to do exactly as your 'hello' application to
> see if I could compile and link.
> Among some other output, I got this message on 'make
> O=obj_path':
> Library dependencies missing: stdlibs in directory
> '/home/incal/core/l4re-snapshot-2013123021/src/l4/pkg/hi/server/src';
> aborting.
> Cflags dependencies missing: stdlibs in directory
>     '/home/incal/core/l4re-snapshot-2013123021/src/l4/pkg/hi/server/src';
>     aborting.  Stop.
> Before I did that, it told me to 'make O=obj_path
> config' from src/l4, which I did, though I didn't setup
> anything explicitly. I had to fetch 'pkg-config' from
> the repos, but that worked great, only it wouldn't work
> less the terminal had at least 80 columns - turns out,
> in the Linux VT, I have 73 columns (i.e., char width),
> and in X, in urxvt 78. But xterm was configurable in
> .Xresources like this:
> xterm*geometry:        80x28
> Just sayin'.

I can recommend 'make textconfig' and 'make oldconfig' for your

> What is "stdlibs"? It sounds like the C standard
> library except for the trailing "s".

It's an alias in the build system to group the necessary libraries
required for building a program.
Did you build the tree to a successful end before you compiled your own
> I tried to remove the "include" stuff from the C
> source, as well as the 'puts' and 'sleep' (to just make
> it return 0) - this, I thought, would make it
> independent of any library routines, however, I got the
> same error message.

You need to build the tree so that all that functionality is available
for your program. The error you're getting happens before anything is
built because of the requirements for building as listed in the Makefile
are not fulfilled and thus building makes no sense because it would

Adam                 adam at

More information about the l4-hackers mailing list