Library dependencies missing: stdlibs in directory

Emanuel Berg emanuel.berg.8573 at student.uu.se
Fri Feb 21 01:09:40 CET 2014


Marcus Hähnel <mhaehnel at os.inf.tu-dresden.de> writes:

> I hope this gets you started...

Yes, that worked!

Now compilation time is normal.

Amazing thing is, I didn't do half (actually close to
zero) of that stuff the first time around, so how it
still worked is a mystery!

This - now modified with new paths -

qhello () {
    core=~/core
    fiasco=$core/l4re-snapshot-2013123021/src/kernel/fiasco/fiasco-build/fiasco
    x86_bin=$core/l4re-build/bin/x86_586
    l4f=$x86_bin/l4f

    DISPLAY=":0" \
    qemu-system-i386 \
        -kernel $x86_bin/bootstrap \
        -append "bootstrap -modaddr 0x01100000" \
        -initrd "$fiasco -serial_esc\
,$l4f/sigma0\
,$l4f/moe --init=rom/$1\
,$l4f/l4re\
,$l4f/$1" \
        -serial stdio
}

- must have been a pretty good function, right? :)

Perhaps you should publish that tutorial on the home
page?

If you don't count the O= stuff,

Makeconf.local
Makeconf.boot
mk/tmpl/inst

were all new to me.

As for

> 4) To have a new configuration in the dialog window
> of the qemu boot to choose from edit
> src/l4/conf/modules.list and add a new entry. I used:
> entry myhello roottask moe --init=rom/myhello module
> l4re module myhello

this brings me to another thing, namely - how do you
know what modules you need? They seem to correspond to
the -initrd options (in the qemu wrapper, above).

-- 
underground experts united:
http://user.it.uu.se/~embe8573



More information about the l4-hackers mailing list