Library dependencies missing: stdlibs in directory

Emanuel Berg emanuel.berg.8573 at student.uu.se
Fri Feb 21 20:58:56 CET 2014


Björn Döbel <doebel at os.inf.tu-dresden.de> writes:

>> Amazing thing is, I didn't do half (actually close
>> to zero) of that stuff the first time around, so how
>> it still worked is a mystery!
>
> Fact is, it didn't.

I got the same result for the simple hello world demo.

What didn't work was compilation - or rather, that
"worked", only it unintentionally included - I don't
know - perhaps the whole L4Re?

You might remember I said compilation time was crazy
and you told me several times it was normal, this was
the remap of the C library, etc. On the other hand,
obviously it was impossible for you to suspect the O=
error, and the lesson is perhaps you should publish
code first thing, instead of as a last resort.

>> were all new to me.
>
> Done quoting for now.
>
> We highly appreciate any hints on how to improve that
> documentation.  Claiming it isn't there doesn't help
> us a lot, though.

Hold it - I have never said there isn't any
documentation - I said I have never seen or read it
(apart from those general microkernel descriptions,
which were good). I will read every article you
mention, including this README file, which you mention
in a very negativistic way, but - I guess it's OK if
you really thought I said "there isn't any
documentation".

But actually I can say the style I prefer. Check out
the documentation for Gnus [1]. They (or perhaps "he")
has collected everything in one PDF, suitable for
printing. Second best (or they complement each other, I
guess) is just a list of links to individual articles
and tutorials.

[1] http://www.gnus.org/manual.html

-- 
underground experts united:
http://user.it.uu.se/~embe8573



More information about the l4-hackers mailing list