Fwd: In Freescale i.MX6q_sabre_sd,The problem booting Helloworld + L4 + Fiasco

taeung treeze.taeung at gmail.com
Mon Mar 17 14:29:24 CET 2014


I'm so sorry.
I have questioned rashly.

I have tried to rebuild L4re, reassigning correctly path to L4re build tree.
So,i have solved this problem.

-------- Original Message --------
Subject: 	In Freescale i.MX6q_sabre_sd,The problem booting Helloworld + 
L4 + Fiasco
Date: 	Mon, 17 Mar 2014 22:12:53 +0900
From: 	taeung <treeze.taeung at gmail.com>
To: 	l4-hackers at os.inf.tu-dresden.de



Hello, L4 hackers.

I have one question. please help me..

I have failed booting 'L4 Linux + L4 + Fiasco' on my board(Freescale 
i.MX6 Quad SABRE SD : Cortex-A9 , ARMv7)
So, i'm try to boot 'Helloword + L4 + Fiasco' on my board

Such as..

|$ svn cathttp://svn.tudos.org/repos/oc/tudos/trunk/repomgr  | perl - inithttp://svn.tudos.org/repos/oc/tudos  fiasco l4re

|

1. L4 Re : configure and build (Success)

|||==========================================================================|
$ mkdir -p /path/to/obj/tudos
|$ make O=/path/to/obj/tudos oldconfig
$ make O=/path/to/obj/tudos -j2|

|==========================================================================

|

|2. Fiasco : configure and build (Success)|
||

|==========================================================================

$ cd /somedir/tudos/src/kernel/fiasco
$ make BUILDDIR=/path/to/obj/fiasco
$ cd /path/to/obj/fiasco
$ make menuconfig
$ make
==========================================================================

3. But,when i try to 'make uimage' or 'make qemu', error is happened.

such as..

==========================================================================

root at taeung-MS-7798:/path/to/obj2/tudos# make uimage E=hello-cfg 
MODULE_SEARCH_PATH=/path/to/obj2/fiasco/
make[1]: Entering directory `/home/taeung/Hello_test_l4/src/l4'
=========== Updating RAM_BASE for platform imx6 to 0x10000000 =========
   ... Regenerating RAM_BASE settings
Library dependencies missing: libc_minimal cxx_util cxx_io cxx_base 
cxx_io_kdebug l4sys-direct l4sys in directory 
'/home/taeung/Hello_test_l4/src/l4/pkg/sigma0/server/src'; aborting.
/home/taeung/Hello_test_l4/src/l4/mk/binary.inc:348: *** Cflags 
dependencies missing: libc_minimal cxx_util cxx_io cxx_base 
cxx_io_kdebug l4sys-direct l4sys in directory 
'/home/taeung/Hello_test_l4/src/l4/pkg/sigma0/server/src'; aborting..  Stop.
make[2]: *** 
[/path/to/obj2/tudos/pkg/sigma0/server/src/OBJ-arm_armv7a-l4f] Error 2
make[1]: *** [check_and_adjust_ram_base] Error 2

==========================================================================

|<< My Question >>
Although i search of '|Library dependencies missing: libc_minimal 
cxx_util cxx_io cxx_base cxx_io_kdebug l4sys-direct l4sys|' in google.com,
i could'nt get information about this error.
I don't know why the problem is happened updating |'RAM_BASE for 
platform imx6 to 0x10000000'.
|
|| Please any help..

/Regards,

Taeung Song | Student of Computer Engineering
Hansung University./




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20140317/fba7612e/attachment.html>


More information about the l4-hackers mailing list