compile l4re for arm

Alexis Fajardo Moya afmoya at uclv.cu
Fri Mar 21 20:27:43 CET 2014


Hello,
             I'm trying  to do the same procedure than Waldo. I have 
fiasco compiled in a configured buildir; the same for l4re. I'm using 
the arm-2012.03 toolchain.

When I execute inside l4re builddir the command:

make -j2 elfimage E=hello O=/home/afmoya/builds/l4re.exynos4 MODULE_SEARCH_PATH=/home/afmoya/builds/foc.exynos4 SYSTEM_TARGET=/usr/local/arm-2012.03/bin/arm-none-linux-gnueabi-


it generates three linked files in the image directory of the l4re 
builddir. They reference another three files located in 
l4re.exynos4/bin/arm_armv7a. The generated files are:

  *

    bootstrap_hello.elf,

  *

    bootstrap.elf and

  *

    bootstrap_hello

when I execute Qemu with the following arguments

qemu-system-arm -m 256 -serial mon:stdio  -kernel bootstrap_hello.elf


returns

qemu: fatal: Trying to execute code outside RAM or ROM at 0x41000000

R00=00000000 R01=00000000 R02=00000000 R03=00000000

R04=00000000 R05=00000000 R06=00000000 R07=00000000

R08=00000000 R09=00000000 R10=00000000 R11=00000000

R12=00000000 R13=00000000 R14=00000000 R15=41000000

PSR=400001d3 -Z-- A svc32

s00=00000000 s01=00000000 d00=0000000000000000

s02=00000000 s03=00000000 d01=0000000000000000

s04=00000000 s05=00000000 d02=0000000000000000

s06=00000000 s07=00000000 d03=0000000000000000

s08=00000000 s09=00000000 d04=0000000000000000

s10=00000000 s11=00000000 d05=0000000000000000

s12=00000000 s13=00000000 d06=0000000000000000

s14=00000000 s15=00000000 d07=0000000000000000

s16=00000000 s17=00000000 d08=0000000000000000

s18=00000000 s19=00000000 d09=0000000000000000

s20=00000000 s21=00000000 d10=0000000000000000

s22=00000000 s23=00000000 d11=0000000000000000

s24=00000000 s25=00000000 d12=0000000000000000

s26=00000000 s27=00000000 d13=0000000000000000

s28=00000000 s29=00000000 d14=0000000000000000

s30=00000000 s31=00000000 d15=0000000000000000

FPSCR: 00000000

Abortado (`core' generado)

I tested all the three files and the result is the same.

I use the source code from l4re-snapshot-2013081908 and configure fiasco 
and l4re for exynos4 platform.

Best regards!!



El 21/03/14 21:49, Waldo escribió:
> Hi, i am running the hello world example for the arm realview 
> (exynos4412), and i don't how create a elfimage to run the example, i 
> compile the fiasco and l4re for arm, but the elfimage is not generated.
>
>
> _______________________________________________
> l4-hackers mailing list
> l4-hackers at os.inf.tu-dresden.de
> http://os.inf.tu-dresden.de/mailman/listinfo/l4-hackers

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20140321/1dedb292/attachment.html>


More information about the l4-hackers mailing list