std::cin in Fiasco/L4Re (with 'make qemu')

Adam Lackorzynski adam at os.inf.tu-dresden.de
Thu Apr 3 23:04:53 CEST 2014


On Thu Apr 03, 2014 at 08:45:21 +0200, Bjoern Doebel wrote:
> On 03.04.2014 01:02, Emanuel Berg wrote:
> > Adam Lackorzynski <adam at os.inf.tu-dresden.de> writes:
> > 
> >> I'm not sure where you enter this.  For me, the following works
> >> quite fine:
> > 
> > I tried it in xterm and it was the same thing. But after the
> > assertion failed (the C++ assert, due to the inconsistent read),
> > execution seemingly "falls back" to the qemu prompt (actually it is
> > never anywhere else) - which looks like this: (qemu) - so I thought
> > I'd hit the digit again (the presumed input). And indeed, it 
> > produced the same error message ('unknown command') - so the
> > problem is: the software (running on Fiasco/L4Re, running on qemu)
> > isn't getting the stdin, as that is intercepted by *qemu* (and
> > interpreted as a command, as it says). So it doesn't matter how we
> > twist it: getchar, scanf (hex or decimal), std::cin, or whatever
> > else we can think of to try.
> 
> Could you tell us how exactly you are starting qemu?

You're typing into Qemu's monitor, just try typing 'help' or 'quit'. Now
we're wondering how your Qemu is getting into this mode of operation.
Any -monitor options there?



Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/



More information about the l4-hackers mailing list