Fiasco.OC and qemu vexpress machine model

Michele Paolino m.paolino at virtualopensystems.com
Tue Apr 15 17:26:36 CEST 2014


Hello Adam,

On 14/04/2014 23:53, Adam Lackorzynski wrote:
> Hi,
>
> On Mon Apr 14, 2014 at 11:35:25 +0200, Michele Paolino wrote:
>> I'm trying to execute Fiasco.OC along with the hello module using qemu and
>> the vexpress machine model. For both A9 and A15 cpus the system hangs at
>> "Starting kernel fiasco". It seems that something (the UART driver?)
>> prevents the system to log the kernel boot to the screen.
>>
>> I compiled the image using 'make qemu' in L4RE, and the vm is executed with
>> the argument -nographic.
>>
>> Can you confirm this? Do you have any suggestion to solve it?
>>
>> Here below you can find the log of the A15 boot process:
> Did you launch make qemu with PT=rv_vexpress_a15 and did the launch pick
> up the right Fiasco binary, i.e. that one configured for vexpress-a15?

Executing "make qemu O=../build PT=rv_vexpress_a15 E=hello" results in 
the following:

       Image size(s) in bytes:
                 bootstrap_hello.elf:  917888
       Start address: 0x81000000
       --> Build-Nr: 2
    QEmu-cmd: qemu-system-arm -kernel
    /home/neonum6/l4re-core-2014022818/src/build/images/bootstrap.elf
    -nographic -M vexpress-a15 -m 256


And soon after the log of the boot is exactly the one I posted before. I 
assume that what is in build/images/ is the right binary (bootstrap.elf 
is a symbolic link to 
build/pkg/bootstrap/server/src/OBJ-arm_armv7a/bootstrap.elf), should I 
check elsewhere?

ps: I tried to investigate about the status of the CPU registers using 
GDB, the info all-registers command returns always the same value for 
all the registers.

Regards,
Michele


>
>
> Adam


-- 
Michele Paolino

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20140415/85b4cf7a/attachment.html>


More information about the l4-hackers mailing list