How to secure Ethernet environment on L4 Linux ?

Taeung treeze.taeung at
Fri Apr 18 13:24:09 CEST 2014

Hello, Adam and L4 Hackers.
Thanks for answering.

When I run 'ifconfig', nothing have happened.
I guess that the cause is /etc folder in ramdisk is not enough to run 'init'.

Would you mind if I ask you another question ?

Must also I modify '' ?
or must I modify 'l4lx_xs.cfg' ?
or Do not I need do it ?

If I have to modify them , how to modify  ?
(I'm using Freescale imx6q SABRE SD board.)

If you give a bit me hints, I'd appreciate.

I really want to secure Ethernet on L4 Linux...

For reference.

I'm using 'entry L4Linux_XS' as follows
entry L4Linux_XS
roottask moe rom/l4lx_xs.cfg
module l4re
module ned
module l4lx_xs.cfg
module io
module vmlinuz.arm
module ramdisk-arm.rd
======================== in example folder is..
   NIC => new Device()
     .hid = "smsc911x";
     new-res Mmio(0x4e000000 .. 0x4e000fff);
     new-res Irq(60);

l4lx => new System_bus()
   NIC => wrap(hw-root.NIC);
l4lx_xs.cfg is ..
-- vim:set ft=lua:

local lxname = "vmlinuz";
if L4.Info.arch() == "arm" then
   lxname = "vmlinuz.arm";

   { caps = {
       log = L4.Env.log:m("rws"),
     l4re_dbg = L4.Dbg.Warn,
     log = { "l4linux", "yellow" },
   "rom/" .. lxname .. " mem=64M console=ttyLv0 l4x_rd=rom/ramdisk-" ..  L4.Info.arch() .. ".rd root=1:0 ramdisk_size=4000 init=/bin/sh");

- Taeung -

Message: 1
Date: Mon, 14 Apr 2014 23:48:27 +0200
From: Adam Lackorzynski<adam at>
To:l4-hackers at
Subject: Re: How to secure Ethernet environment on L4 Linux ?
Message-ID:<20140414214826.GC6533 at>
Content-Type: text/plain; charset=iso-8859-1

On Fri Apr 11, 2014 at 10:28:39 +0900, Taeung wrote:

> After I succeeded putting other package in ramdisk, I'm trying to take
> Ethernet on L4 Linux.
> When I built L4 Linux , I've configured '[*]Network support ' and
> '[*]Network device driver support'.
> I've copied 'etc' folder from other file system and put it in ramdisk.
> And I've put somethings about Network in ramdisk.
> Manually I've mounted '/proc' and '/sys' and tried to run command 'if -a'.
> But I've failed secure Ethernet environment on L4 Linux.
> To put it concretely, I was not able to run command 'ifup -a' successfully.

Does ifconfig show the proper network interface?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the l4-hackers mailing list