build error: [kobject_mapdb.o] error

Adam Lackorzynski adam at os.inf.tu-dresden.de
Wed Apr 23 00:01:24 CEST 2014


On Tue Apr 22, 2014 at 15:28:16 +0900, Irvanda Kurniadi wrote:
> I have a problem in building l4/fiasco for arm. I'm using ubuntu 11.10
> 64-bit and want to build l4/fiasco for arm9. For cross compiler, I'm using
> Sourcery_G++_Lite. For the snapshot, I'm using current snapshot
> l4re-snapshot-2014022818. Then, when I tried to build the l4/fiasco, I got
> the error message shown in [1.error message]. Have you ever built l4/fiasco
> for arm9 over ubuntu 11.10 64-bit? I think this is just a compiler problem.
> If you know about this problem, please let me know to solve this problem.

I also think this is just a compiler problem. Is your g++ older than
4.5? Then you'll need a more recent version (any version should do).


Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/



More information about the l4-hackers mailing list