Can not L4 linux support 'Atheros AR8031-AL1A' Ethernet Driver ?

Adam Lackorzynski adam at os.inf.tu-dresden.de
Wed Apr 23 00:17:20 CEST 2014


On Tue Apr 22, 2014 at 21:55:08 +0900, Taeung wrote:
> I'm trying to secure Ethernet environment on L4 Linux. (using Freescale imx6
> SABRE SD board)
> 
> My board's Ethernet is 'Qualcomm Atheros AR8031-AL1A Gigabit Ethernet'.
> 
> I've found source code for Ethernet Driver.
> Folder name is '/l4linux/drivers/net/ethernet/atheros'.
> 
> But, the folder only contain   'ATL1c' and  'ATL1e', 'ALX', 'ATLX'.
> I guess 'atheros' driver in L4 Linux don't support my ethernet driver.

L4Linux has the same drivers as native Linux, so if the driver is in
Linux it is also in L4Linux (in the same version). There seems to be
support for this type of network in the imx6 support code. So does the
network work with the native Linux of the same version?



Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/



More information about the l4-hackers mailing list