L4linux: cpu and core [comprehension question]

Irvanda Kurniadi irvanda.k at gmail.com
Fri Apr 25 04:01:24 CEST 2014

On Fri, Apr 25, 2014 at 6:40 AM, Adam Lackorzynski <
adam at os.inf.tu-dresden.de> wrote:

> Hi,
> On Thu Apr 24, 2014 at 16:47:59 +0900, Irvanda Kurniadi wrote:
> > I am a little bit confused about the term of cpu and core in l4linux. I
> > have a system with 8 processor intel xeon E5606 with 4 cores in each cpu.
> According to the Internet, an E5606 is a quadcore CPU without
> hyperthreading. Do you mean that you have an 8 socket system and thus 32
> cores?
> Yes I do, it means 8 sockets.

> > I'm going to maximize it to become the maximum number of cores in all
> cpus.
> > But I am confused in determining the l4x_cpus that what is the term cpu
> in
> > here? Is it literally cpu or the number of threads that can be handled in
> > each core?
> l4x_cpus describes how many virtual CPU (L4) threads L4Linux shall
> create. This is purely software and has no relation to Hyperthreads or
> similar.

> I run an openmp hello world apps over l4linux. I call the
> > omp_get_thread_num() and I got 4 threads in the result. Are these 4
> threads
> So you L4Linux is running with 4 vCPUs? (See /proc/cpuinfo for example.)
> OK, I got it. I put 32 in l4x_cpus, then I check it in /proc/cpuinfo. I
found that there are only 25 vCpus created from vcpu 0 - 24. At the second
attempt, there are 28 vCpus created. At the third attempt, there are 32
vCpus created. Then at fourth attempt there are 31 vCpus created. The
number of vCpu created isn't always shown with the certain number. Is it
normal? I don't think this is a normal condition.

> > obtained from 4 cores in single cpu? So, if I'm right, how can I optimize
> > to use all of the cpu existed in the system? I've tried to use l4x_cpus=8
> > and l4x_cpus=32, but those commands doesn't work for me. In my opinion,
> if
> Doesn't work means it does not get larger than 4? Your L4Linux
> configuration also needs to support as many CPUs.

Yeah, the problem is located in fiasco and smp (on qemu) configuration.
After I read your explanation, I change the max cpus into
nr_sockets*nr_cores and also change the smp into -smp 32.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20140425/755aa5cb/attachment.html>

More information about the l4-hackers mailing list