Facing l4x-evict_task problem in L4Linux

Irvanda Kurniadi irvanda.k at gmail.com
Fri May 9 11:08:49 CEST 2014

Hi hackers,

I want to ask you about my problem in running mpi-program over L4Linux. I'm
usinng ubuntu 12.04 kernel with gnu libc-2.15. I put the library from
/lib/i386-linux-gnu/ to /lib in my custom ramdisk. Then I put the library
that is compiled in the kernel's host to the /usr/lib in my custom ramdisk.
I also put my mpi hello program and my own mpi program which are compiled
in the kernel's host (I mean in ubuntu 12.04 with libc-2.15). I'm using
MPICH3 for the mpi library and I use gforker process manager. When I run
the mpi Hello program, it can run properly (I invoke "mpiexec -n 4
./mpi_hello and there are 4 output from different 4 different processor, it
means the program run properly). Then I run my own mpi application which
also include the tiff, jpeg, amd libstep libraries that I put altogether in
/usr/lib/ in my custom ramdisk. But I got this error message when I invoke
"mpiexec -n 1 ./mpi_program image.tif" or "mpiexec -n 2 ./mpi_program
image.tif" command (shown below).

l4x-evict_tasks: 1089 callbacks suppressed
l4x-evict: Found no process to free
l4x-evict: Found no process to free
l4x-evict: Found no process to free
INFO: rcu_sched detected stalls on CPUs/tasks: { 1} (detected by 0,
t=348877 jiffies, g=4294967184, c=4294967183, q=(5)
sending NMI to all cpus:

and I can't interrupt the running process.

I presume this problem happens because the all of process have been
finalized but the l4linux kernel still think that there is a remaining
process that should be freed. But I'm not sure about this. If you know
about this, plis let me know how to fix it and if you can give me an
explanation about this I will be really grateful.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20140509/038d83c1/attachment.html>

More information about the l4-hackers mailing list