Graphical desktop, l4con, mag

Adam Lackorzynski adam at os.inf.tu-dresden.de
Tue Jun 10 23:17:18 CEST 2014


On Tue Jun 10, 2014 at 14:20:54 -0400, teclis High Elf wrote:
> Ok I solved the build problem. This command:
> 
> 
> *svn cat http://svn.tudos.org/repos/oc/tudos/trunk/repomgr
> <http://svn.tudos.org/repos/oc/tudos/trunk/repomgr> | perl - init
> http://svn.tudos.org/repos/oc/tudos <http://svn.tudos.org/repos/oc/tudos>
> fiasco l4re*
> 
> from: http://l4re.org/download.html doesn't grab all the l4 packages.

Indeed, it only checks out a subset. To fetch all, 'all' could be
specified instead of 'fiasco l4re'.

> I downloaded the latest tarball snapshot and they were all there.

The other possibility.

> and it built ok. Now when it runs fbdrv page faults. Has anyone seen this
> before? danke
> 
> fbdrv   | Trying execution of ``set VBE mode'' using x86emu
> fbdrv   | Found VESA BIOS version 2.0
> fbdrv   | OEM VGABIOS Cirrus extension
> fbdrv   | Scanning for 'best' possible mode:
> fbdrv   | Trying to read DDC info
> fbdrv   | DDC function not supported
> fbdrv   | EDID not available (-19), finding best possible mode ...
> fbdrv   | Mode: 0x101     640x480 at 8, RGB: 0(0):0(0):0(0) mode: bb
> fbdrv   | Mode: 0x110    640x480 at 15, RGB: 10(5):5(5):0(5) mode: bb
> fbdrv   | Mode: 0x111    640x480 at 16, RGB: 11(5):5(6):0(5) mode: bb
> fbdrv   | Mode: 0x112    640x480 at 24, RGB: 16(8):8(8):0(8) mode: bb
> fbdrv   | Mode: 0x103     800x600 at 8, RGB: 0(0):0(0):0(0) mode: bb
> fbdrv   | Mode: 0x113    800x600 at 15, RGB: 10(5):5(5):0(5) mode: bb
> fbdrv   | Mode: 0x114    800x600 at 16, RGB: 11(5):5(6):0(5) mode: bb
> fbdrv   | Mode: 0x115    800x600 at 24, RGB: 16(8):8(8):0(8) mode: bb
> fbdrv   | Mode: 0x105    1024x768 at 8, RGB: 0(0):0(0):0(0) mode: bb
> fbdrv   | Mode: 0x116   1024x768 at 15, RGB: 10(5):5(5):0(5) mode: bb
> fbdrv   | Mode: 0x117   1024x768 at 16, RGB: 11(5):5(6):0(5) mode: bb
> fbdrv   | Mode: 0x118   1024x768 at 24, RGB: 16(8):8(8):0(8) mode: bb
> fbdrv   | Mode: 0x107   1280x1024 at 8, RGB: 0(0):0(0):0(0) mode: bb
> fbdrv   | Mode: 0x119  1280x1024 at 15, RGB: 10(5):5(5):0(5) mode: bb
> fbdrv   | Mode: 0x11a  1280x1024 at 16, RGB: 11(5):5(6):0(5) mode: bb
> fbdrv   | Choosen mode:
> fbdrv   | Mode: 0x11a  1280x1024 at 16, RGB: 11(5):5(6):0(5) mode: bb
> fbdrv   | To force a specific setting use a '-m <mode>' option.
> fbdrv   | L4Re[rm]: mapping for page fault failed with -34 @1a0000
> pc=1006452
> fbdrv   | L4Re: unhandled exception: pc=0x1006452

This looks like io does not like to hand out the framebuffer memory.
Any change when specifying, for example, -m 0x114 ?
Does io say something noteworthy, possibly with some -v options
supplied?



Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/



More information about the l4-hackers mailing list